2

Most of my songs on my iPhone are ripped from CDs. In this case, song information like artist name are typed by myself, saved and synced well to my iPhone through iTunes but some cases, the information is automatically changed then saved. I'm perfectly sure it's the songs from artists that i've purchased from iTunes before.

For example, if I ripped songs then put the artist name with all capitalized like "KING CRIMSON", and sync to my iPhone, it shows me the exact same artist name.

But if the songs were from artist that I purchased before from iTunes, then the artist name capitalized is changed as uppercase remained only on first letter automatically during sync process (e.g., "BEATLES" → "Beatles")

The point is that even songs ripped, not purchased from iTunes are changed, too if the artist's songs were once purchased before.

See screenshots below—first one is song information ripped from CD (you can see artist name all capitalized) and second one is captured image from my iPhone (artist name automatically changed)

Can anyone help me with how to fix the uppercased artist name?

1

Try turning off a setting called, "Share details about your library with Apple". In iTunes, goto Preferences, Store Preferences and uncheck that option.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .