6

I have iTunes 12 and it will not play albums in order - just one song at a time. I have tried all kinds of things to fix this.

Something I noticed is that none of the songs are checked any more and I don't know what that means.

I can't figure this out. Help.

Thanks

  • You've set the 'Repeat' value correctly in iTune's Controls menu? – Wayfaring Stranger Feb 24 '15 at 2:48
  • 1
    Are you playing your music from the specifically from the Album view (the view where the album art is on the right, the tracks are on the left, and the background is a blurred version of the album art)? – Cal Stephens Feb 24 '15 at 2:50
8

iTunes doesn't move to the next song by default, it moves to the next checked song.

If all are unchecked, that's your issue.

To recheck, in 'Songs' mode, select the top one, scroll to the bottom, shift/click the last one.
Right click > check selection.
[it might say 'tick' not check, I'm not sure if that's input language-dependant…
US check == UK tick]

2

There are multiple "views" in iTunes that allow you to play songs. As Tetsujin mentioned in his answer, iTunes only plays songs that are checked. However, this is only partially correct.

When you are viewing your songs from the Songs view, which is just one long list of all the songs in your library, then this is correct. Songs are played only if the checkbox is checked.

However, there is also an Album and an Artist view. To play an entire album, using the Album view (or Artist view) makes more sense, as you can select the play button for the album, and all the songs will play.

0

In response to Charlie74, also in Album and Artist view you are able to check and uncheck songs. Just make sure you select all the songs, right click and select check selection. After that the album will play.

0
  1. If you click the box where it shows the song and red progress bar.
  2. then go down towards the bottom and locate the two curved arrows that create an oval.
  3. then check if it is highlighted a darker gray
  4. if so click it and should be unhighlighted then it should work.

You must log in to answer this question.

protected by Community Apr 23 '16 at 11:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .