0

I am facing very sluggish performance in my MacBook Pro after I upgraded it to Yosemite. Mine is 8GB, i7 mid 2012 system.

Usually I find my unused RAM <25MB even if I work in terminal, say around 8 Safari tabs open (excluded fb) and some light-weight programming editor open.

I remember I never faced such sluggish performance in Mavericks or Mountain Lion. I have closed all unwanted graphical effects, but still no improvement on performance.

Any suggestions?


Below is the screenshot of my activity monitor: enter image description here enter image description here

Please note my Preview was closed while I took this shot; which is in a way super weird.


CPU usage: enter image description here

  • You're not as short of memory as you think you are. The "File Cache" is memory that's being used to cache files simply because it's not needed for anything else, and is available for applications to use. It counts as free memory. – Mike Scott Feb 23 '15 at 8:06
  • I would bet on a high kernel_task CPU usage. – Matthieu Riegler Feb 23 '15 at 9:13
  • It is not about memory. Please take a look here: apple.stackexchange.com/questions/153397/… – Rilakkuma Feb 23 '15 at 9:55
  • Can you please sort it by '%CPU', we want to see the CPU hogging processes at the top. – nohillside Feb 24 '15 at 5:30
  • @patrix refresh – ikis Feb 24 '15 at 5:36
1

Beginning with Mavericks, Apple began using a different way of utilizing RAM called memory compression. That is why the used is so high.

Wikipedia Virtual Memory Compression

Two things you can do are to remove the contents of the saved application state folder in your user library and remove the swap files in the /var/vm/ folder at the root of your drive. Once these have been removed, restart your computer. Let me know what you got going on after that!

  • didn't help much. – ikis Feb 26 '15 at 20:34
  • If you do not have a retina, I would remove the hard drive and connect the drive externally to the computer to see if your hard drive cable is causing trouble. Also, if you have FileVault enabled, turn it off. – fingaz Feb 26 '15 at 20:37
0

The answer is simple: after using your MBP for several hours, the Yosemite UI will become really sluggish. Try restarting your MBP. Does the UI seem a little snappier? Yosemite is simply not as optimized for UI speed as previous OS Xs. I have a 2013 13" MBPr.

  • Most of the time I work on projects which prevents me from restarting the system. I know it is the last resort, but I can't afford to do so. – ikis Feb 26 '15 at 20:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .