0

When I have an application that I use the contextual menu for 'Show in Finder' it opens finder, but it always opens it in the 1st space, never in the current space i'm in. For example, I have Xcode in space 3 always, and when I right click and show item in finder it opens the finder window in Space 1 always, same across all other applications and instances. Even worse, it doesn't autonomically teleport to the 1st space I have to manually do it. I'm running 3 monitors which makes it a little more aggrevating

Heres my settings : pic1

Altering any of the group choices etc don't have any effect.

I would love to have it open in the active or current space i'm in.

1

You may need to try a little experimentation to get closest to what you need [also it may not always work as expected since Yosemite]

If you right click the Finder icon in the Dock you get the options of

  • All Desktops
  • This Desktop
  • Desktop n [only shows if it is currently assigned to another Space]
  • None

Each has advantages & disadvantages.

  • All - will carry every Finder window with you to every Space - can be irritating.
  • This - ought to return you to the assigned Space with any move that brings the Finder to the front, i.e. click on Desktop. [This has been a bit broken since Yosemite & doesn't always work]
  • None - should give no specific focussed Space & I think might be the one you need. Any new window should open on your current Space.

enter image description here

1
  • 1
    Damn I'm dumb ha. Can't believe I forgot about that. Especially when that's how I set my Xcode to always be on 3. Thank you though! I'm a happy camper now – soulshined Feb 23 '15 at 9:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .