3

For years I've been sharing Internet on my MacBookPro Wi-Fi coming from USB connected iPhone. After OSX 10.10 Yosemite things started working erratically and now definitely stopped in 10.10.2.

Hardware connection: iPhone->USB->MacBook Pro (hotspot/tethering active, Internet is working on MBP)

Sharing preferences: "share USB iPhone to computers using Wi-Fi"

Now I'm not getting the usual "arrow up" icon instead of WiFi on the menubar and sharing is not working.

example

Internet sharing from Ethernet to Wi-Fi is working as expected.

During many tests I've been able to activate internet sharing only once, after a long series of SMC resets, disk repair and reboots, but never been able to reproduce it anymore.

After installing 10.10.1 everything seemed back to normal. Just tried now with 10.10.2 and it's not working.

In system logs I'm getting this strange message:

22/02/15 12:03:34,580 airportd[34]: WARNING: com.apple.preferences.sharing.remoteservice (385) is not entitled for com.apple.wifi.keychain, temporarily allowing request with background priority —— all entitlement requirements will be strictly enforced in a future release

Not sure if it's related.

Any clues?

Someone on Apple Communities says "sharing from iPhone is no more supported...", then why device is still there in the menu and you don't get any warning?

  • I'm having the exact same problem. If you send the iPhone's connection via Bluetooth to the Mac, you can then share that via WiFi without any problems. So it is capable of sharing the connection, but it just doesn't like the iPhone USB... – cathalog Apr 13 '15 at 18:10
  • Thanks @cathalog tethering via Bluetooth instead of USB worked for me. Total lack of info from OS X here is confusing though! – ZoFreX Jun 11 '15 at 23:11
  • No solutions for getting USB tethering to work? – Makoto Sep 20 '15 at 1:26
  • Update: El Capitan OSX 10.11 (update, no clean install) - does not work either. – thelazydesigner Oct 15 '15 at 14:21
-1

Using the Bluetooth connection to my iPhone works, while USB does not.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .