2

Mavericks on Macbook Pro Retina A1398 (US keyboard with horizontal Enter) shows Japanese keyboard (JIS, with vertical Enter) on enabled keyboard viewer. How do I make Mavericks to recognize and to show its native US Keyboard layout? I have tried to reset SMC and PRAM with no success.
p.s. I have tried changing input sources to U.S. as well - does not change the orientation of return on bluish keyboard on the right - mac OS still thinks I have JIS...

2
  • Does keyboard viewer show the topmost leftmost character key to be a 1? If not, what? Feb 21, 2015 at 23:34
  • It shows 1 in the top left corner...
    – Alex
    Feb 22, 2015 at 17:28

2 Answers 2

3

It sounds like your machine is not recognizing the "keyboard type" correctly, thinking you have a JIS (or ISO) type instead of ANSI. See this article for some suggestions on fixing it:

http://m10lmac.blogspot.com/2009/12/fixing-keyboard-type-problems.html

8
  • Thank you, Tom! You've got it. Unfortunately Mavericks do not have spatial file suggested in the article no more and I've tried reseting PRAM and SMC already with no effect. I think it is something to do with internal keyboard marking since mac stubbornly sees JIS instead of ANSI...
    – Alex
    Feb 22, 2015 at 17:25
  • Did you try the Terminal Command? Feb 22, 2015 at 17:47
  • Yes, Tom! OS recognizes my ANSI as JIS. So it finds no issues. *2015-02-22 20:57:25.351 KeyboardSetupAssistant[659:507] No unknown keyboard connected - terminating logout *
    – Alex
    Feb 22, 2015 at 17:57
  • I am afraid that I have to replace the topcase and that will take forever...
    – Alex
    Feb 22, 2015 at 17:59
  • Similar issue, but with external keyboard... forums.macrumors.com/showthread.php?t=1582071
    – Alex
    Feb 22, 2015 at 18:01
-1

Go to System Preferences > Keyboard > Input Sources tab and click the "+" key to add the US Keyboard:

enter image description here

1
  • Thank you, Icon. That does not change the orientation of the Return key. I do actually use U.S. input source already. Even then the keyboard viewer shows layout vertical enter as it probably thinks that I might have actual Japanese keyboard, which is nonsense. I am trying to understand how to change the way OSX thinks about my actual keyboard....
    – Alex
    Feb 21, 2015 at 21:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .