2

Messages on Yosemite used to work fine until this morning, repeatedly asking me for my Apple ID password. Months ago I had setup 2 factor authentication for my Apple ID, but it never complained. So I set up an app specific password, Facetime took it no problem, Messages didn't and kept asking for my password. I quit, log out, restart, disable/enable from my phone, nothing works. So I disable 2FA, try again and now Messages gives me a blank window when it starts.

Is there any way I can reset it somehow ?

Blank Messages window

  • what is 2FA ?.. does your Apple ID work on app store? – Ruskes Feb 21 '15 at 20:27
  • did you repair permissions in Disk utility ? – Ruskes Feb 21 '15 at 20:32
  • @Buscar웃 sorry, 2FA is two factor authentication. Just fixed the permissions (there was a bunch of problems for Messages) but it didn't help. Should I have restarted ? – blackbird Feb 21 '15 at 20:57
  • log out log in will do, or restart if you like – Ruskes Feb 21 '15 at 21:33
  • Nope, doesn't change anything :( – blackbird Feb 21 '15 at 22:24
0

I was certain this problem was related to two factor authentication on my Apple ID because problems started happening when I tried to login. After more investigation it turns out it was a font conflict problem preventing the UI from starting.

I found an error message in the console application regarding NSString which, after a lot of googling indicated a font problem. I then cleared the font cache and reset all non standard fonts in font book and restarted OSX. The app now works

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .