I've been seeing this error a lot lately:

enter image description here

Could not save [file] because write access was not granted

I've checked all the standard reasons why permission to save a file might be denied:

  • The file is not open in any other application
  • The user does have access to the drive and directory
  • No other users on a network are accessing the file
  • The file is not read-only
  • No other save operations are happening
  • The connection to the drive is fine

I've seen this happen on Lion and Mavericks. I've only ever seen it on a Mac, and only ever with Photoshop, with .PSD files.

  • So what is the final answer on this annoying problem, anyone? Using El Capitan 10.11.3 Going to update, however sounds like that fixes nothing. I have an older Mac at home with CS4, never an issue.
    – user180221
    Commented Apr 18, 2016 at 19:37
  • The final answer is the one with the green tick next to it which solves the problem... If you want this to never happen, you can ask that as a separate question with the "ask a question" button at the top of the page. It'll be something to do with types of network connection Commented Apr 18, 2016 at 19:42

5 Answers 5


After some trial and error, I tracked it down to the file being selected in Finder.

It seems like when Finder is displaying a preview of a PSD, it locks the file.

It seems to only happen in this view mode:

enter image description here

Selecting another file in Finder, or switching view mode, or closing the finder window, all prevent this error.

So while Finder is like this, the file won't save:

enter image description here

Clicking off it frees it for saving:

enter image description here

As does switching to this view mode to one that doesn't show a preview:

enter image description here

  • This is a beautifully simple and correct answer!
    – PsychoData
    Commented May 27, 2015 at 18:51
  • To a hideously ridiculous and nonsensical problem! :-) Commented May 27, 2015 at 18:54
  • I wish I could blame adobe, but I think this is apples blunder
    – PsychoData
    Commented May 27, 2015 at 22:49
  • very strange and incovenient... is everybody experiencing this under 10.11 El Capitan?
    – bo-oz
    Commented Nov 10, 2015 at 13:38

IMHO the problem is caused by the SMB protocol, then in fact there are some ”strange process” opened by the Finder. I changed the server protocol for AFP and everything works well. In my case I changed shared folder’s settings in Server app ver. 4.1.5, but this works is mac os x System Preferences as well. The eventual disadvantage – there is no connection of PCs to the server.

  • Interesting, if I remember right the files that were misbehaving for my question were on a network drive and I think it was an SMB connection Commented Sep 9, 2015 at 14:20
  • The previous answer (temporarily locked while Finder is previewing the file) works sporadically but this answer worked 100% of the time. It's definitely something with the way SMB handles the file sharing. Switching to an AFP share works beautifully. Thanks!
    – Mr Rabbit
    Commented May 14, 2019 at 17:01

Alright... So this is my findings after an hour of testing;

The Mac is joined to the domain.

Logged onto the Mac with the local admin account... Connected to the server via smb://server/share as a domain admin and everything worked as normal... I moved files, folders, renamed files, and folders, many times, in and out of root folder, up and down the tree structure throughout sub layers, in all view modes and never got prompted to enter a password.

Logged onto the Mac with "Domain User" account, connected to server as "Domain User" and Finder breaks rather quickly after a few moves of files and folders. Domain User account was configured using Default Domain User Permission level with full control, and without full control, still prompts for password to make changes.

So let's make everybody domain admins... problem solved... just kidding ;)

  • There you go, took 15 seconds to break and prompt for password ;-) i.imgur.com/IyZZTYT.gif
    – Robert
    Commented Jun 12, 2015 at 15:48
  • 1
    Are you sure you posted this in the right place? I don't quite see how it relates to the question. Commented Jun 12, 2015 at 16:13
  • Yes this video example is a direct response to the SMB\Finder permission issue as posted above. It doesn't matter what your doing, moving files\folders in Finder, renaming, saving in Adobe or Finder, doesn't matter which view mode, as a domain users connected to the server share it will break permission.
    – Robert
    Commented Jun 12, 2015 at 16:29
  • It relates directly to what you posted... but testing the "unselecting the file in finder" part does work as you said. My reason for the domain users\domain admin is to demonstrate that it's a permission level error with SMB\Mac. As a domain admin everything work for me, no error, no prompt for password. As a domain user Finder would prompt for a password after a few moves of files. It's certainly a permission level issue with SMB.
    – Robert
    Commented Jun 12, 2015 at 16:38

I've found an answer to this error just duplicate the image twice and then go to image size change it and then press Cmd Z. After that save :)


I'm running Mojave 10.14.4 and running into same issue on a NAS. The files are not selected in the Finder and same permissions error occurs. After performing more tests, it appears that after saving for the first time after opening the file, the permission issues occurs. The second or more saves causes the error.

  • Any chance you got to the bottom of this? Commented Jul 25, 2019 at 14:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .