17

How can I set the default width and height of my Mac terminal window so that it always opens the way I'd like it to. Currently, every time I launch the terminal app, I need to resize it.

enter image description here

13

One way to do it is

  1. Set your window how you would like it,

  2. Go to Window > Save Windows as Group...

screenshot of the save windows as group dialog box

  1. Enter a name next to Save As:

  2. Check "Use window group when Terminal starts"

  3. Click Save

However, after you have launched Terminal, if you chose Terminal > New Window you will still have to resize the window. This is most useful if you want to have multiple terminal windows open at launch.

If you go to Terminal > Preferences > Profiles you can create a (or edit an existing) profile for a terminal window by column and row size which is available at the end of the terminal window title bar (Your screenshot shows a window 80 columns wide and 24 rows tall)

You can then set that profile to the default by pushing the default button (if the default button is ghosted out that group is already the default):

profiles page screenshot with default circled

12

The window should remember its last position. But will change it's size to fit the size you have in the preferences. You can see the current size of yours is the default.

80x24

You can change that in the Profile>Window Tab. (on your default profile)

Window Size

enter image description here

3

You could also create an applescript or automator service. Add scripts menu to menubar and click to launch new window. Or use automator to call the applescript, then define a keyboard command (link to instructions).

tell application "Terminal"
activate
set the bounds of the first window to {140, 0, 1160, 775}
-- x - x position in pixels
-- y - y position in pixels
-- w - width in pixels
-- h - height in pixels
end tell
0

In macOS Sierra (10.12), to set the "new window size part" go to Terminal's preferences and use the General tab to go down to the "New windows open with:" option. For me, selecting "Same profile" worked.

BTW: This is the first and only time I have encountered this problem on macOS. It doesn't occur in macOS High Sierra (10.13), but I had to switch back to Sierra after the last macOS update trashed my machine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .