7

I try to kill a buggy application without success.

I tried the Force Quit… feature in the Apple menu but it doesn't work.

In order to find the PID I tried the following command from the Terminal but it doesn't match anything:

ps aux | grep -i MyApplicationName

The only way to effectively kill it is to restart the system. Sometimes I need to force restart because the buggy application is preventing the system to restart.

I'm running Mac OS X 10.9.5 on a Retina 13' MacBook (late 2013)

  • 1
    Could you tell me which system version do you have? – Eir Nym Feb 20 '15 at 11:05
  • @EirNym I just edit my post – Martin Delille Feb 20 '15 at 11:11
  • I had this issue on 10.9. After I have had moved to 10.10, issue has gone. – Eir Nym Feb 20 '15 at 11:13
  • I'm not confident enough in 10.10 for now: I hear so much bad thing about it like if it was the apple "vista" :-) – Martin Delille Feb 20 '15 at 11:21
  • I'm quit sure this is a bug from the OS. – Martin Delille Feb 20 '15 at 11:22
2

Find the PID in activity monitor then in a terminal run sudo kill -9 PID and voilà

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .