4

A dead key (a key that does not generate a complete character by itself but modifies the character generated by the key struck immediately after) is indicated with a yellow background to previous the final character.

enter image description here

It's perfect when you write black on white, but not when you write white on black, like in some Terminal configurations.

enter image description here

My question is: Where can I change that color?

  • What exactly are dead keys? Can you give an example of a dead key? When I press command, ctrl or any other modifying key there is no yellow background in my terminal. How do I activate 'dead' keys? Are they part of the text encoding? – CousinCocaine Feb 28 '15 at 17:55
  • @CousinCocaine I think they mean like accent marks. The way to write é if you don't want to hold down e and then select the character is to press Option-E and then press e. – user24601 Feb 28 '15 at 18:20
  • @user24601 yes it is (not for accent marks in my case, as I have a French swiss keyboard, but it for greek accent mark) – Maïeul Feb 28 '15 at 19:57
  • I noticed that this is a system wide issue, it is not bound to the Terminal only. Another thing is that this feature is already present in 10.6.8. – CousinCocaine Mar 1 '15 at 8:18
  • yes, it system wide issue. But the problem appears only on White to Black input... – Maïeul Mar 1 '15 at 8:54
1

This isn't a clean fix, but here's a work around:

Keep the Terminal as Black on White but then go to:

System Preferences > Accessibility > Display > Invert Colors

Doing this will change your Terminal (and everything else) to White on Black, but also change the yellow dead key to blue.

enter image description here


You can also turn Invert Colors on and off using a keyboard shortcut if you turn it on in the keyboard preferences:

enter image description here

  • 1
    indeed, that's not stupid, but as many time I use terminal in the same I use other software I want to be white on black... iterm2 is for now the better solution. – Maïeul Mar 13 '15 at 9:54
0

old: I don't know how to fix the dead keys, but there's a better solution (in my opinion), which avoids dead keys altogether. Check out my answer to the question: Accent popup in Terminal.app?.

If you don't like that approach, you might try to dig around in the file Library/Preferences/com.apple.Terminal.plist and see if you can find anything there that might be useful.


edit: Reading some of the comments on the original question, I see that this solution will not work for the OP, but I will still keep it as an answer in case anyone else might have this question and find the information useful.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .