1

I purchased an iMac from a buddy and recently upgraded to Yosemite so I am learning as I go about Macs. However, I decided I wanted it to be quicker so I purchased an OWC SSD to install as a primary and use the 1TB HDD as a secondary. Before the install I wanted to remove everything and that included the partition for Boot Camp that shows up:

enter image description here

After reading several tutorials and watching a few videos it suggested going to Boot Camp Assistant but every time I go I get this:

enter image description here

Per this question "Boot Camp Assistant: “Your disk could not be restored to a single partition." it says Click "Erase" and select "Mac OS Extended (Journaled)" but this doesn't do anything in Yosemite.

I've tried downloading the latest to a USB drive but that doesn't do anything either.

So my question is in Yosemite how do I remove the partition from Macintosh HD completely?

Per comment request:

 #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage                         887.0 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
   4:                  Apple_HFS BOOTCAMP                112.2 GB   disk0s4
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Macintosh HD           *886.6 GB   disk1
                                 Logical Volume on disk0s2
                                 FA247940-D4E9-40AB-AE18-1394D9ED16BE
                                 Unlocked Encrypted
/dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *8.0 GB     disk2
   1:                 DOS_FAT_32 NO NAME                 8.0 GB     disk2s1



CoreStorage logical volume groups (1 found)
|
+-- Logical Volume Group 82672C7C-9FC8-4550-994E-89A0D1E5FC29
    =========================================================
    Name:         Macintosh HD
    Status:       Online
    Size:         887000006656 B (887.0 GB)
    Free Space:   19005440 B (19.0 MB)
    |
    +-< Physical Volume BEA6AD8A-2F7F-42ED-8660-1CF71369B5E3
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk0s2
    |   Status:   Online
    |   Size:     887000006656 B (887.0 GB)
    |
    +-> Logical Volume Family CEA6664F-F5CC-40A8-B5A0-F026C21E7518
        ----------------------------------------------------------
        Encryption Status:       Unlocked
        Encryption Type:         AES-XTS
        Conversion Status:       Complete
        Conversion Direction:    -none-
        Has Encrypted Extents:   Yes
        Fully Secure:            Yes
        Passphrase Required:     Yes
        |
        +-> Logical Volume FA247940-D4E9-40AB-AE18-1394D9ED16BE
            ---------------------------------------------------
            Disk:                  disk1
            Status:                Online
            Size (Total):          886628679680 B (886.6 GB)
            Conversion Progress:   -none-
            Revertible:            Yes (unlock and decryption required)
            LV Name:               Macintosh HD
            Volume Name:           Macintosh HD
            Content Hint:          Apple_HFS


gpt show: /dev/disk0: mediasize=1000204886016; sectorsize=512; blocks=1953525168
gpt show: /dev/disk0: PMBR at sector 0
gpt show: /dev/disk0: Pri GPT at sector 1
gpt show: /dev/disk0: GPT partition: type=C12A7328-F81F-11D2-BA4B-00A0C93EC93B, start=40, size=409600
gpt show: /dev/disk0: GPT partition: type=53746F72-6167-11AA-AA11-00306543ECAC, start=409640, size=1732421888
gpt show: /dev/disk0: GPT partition: type=426F6F74-0000-11AA-AA11-00306543ECAC, start=1732831528, size=1269536
gpt show: /dev/disk0: GPT partition: type=48465300-0000-11AA-AA11-00306543ECAC, start=1734103040, size=219159944
gpt show: /dev/disk0: Sec GPT at sector 1953525167
       start        size  index  contents
           0           1         PMBR
           1           1         Pri GPT header
           2          32         Pri GPT table
          34           6         
          40      409600      1  GPT part - "EFI System Partition"
      409640  1732421888      2  GPT part - "Macintosh HD"
  1732831528     1269536      3  GPT part - "Recovery HD"
  1734101064        1976         
  1734103040   219159944      4  GPT part - "Apple_HFS_Untitled_2"
  1953262984      262151         
  1953525135          32         Sec GPT table
  1953525167           1         Sec GPT header
  • Please open Terminal.app and enter diskutil list diskutil cs list and sudo gpt -r -vvv show -l /dev/disk0 and add the outputs to your question. – klanomath Feb 18 '15 at 22:47
  • @klanomath I have edited the question per your request. – ʀ2ᴅ2 Feb 19 '15 at 3:51
  • Did bmike's answer work or do you still need help? – klanomath Feb 19 '15 at 6:41
  • It worked but by all means if you have a suggestion please add it so it might help someone else. – ʀ2ᴅ2 Feb 19 '15 at 6:44
  • Did you execute sudo gpt -r -vvv... before or after applying bmike's solution? – klanomath Feb 19 '15 at 6:57
1

Boot to the Recovery HD after completing a full back up of the Mac side of things just to be safe.

Open Disk Utility

  • Select the Bootcamp partition and delete it.
  • Then drag the bottom right corner of the Mac partition to expand it back to full size.

Read the warnings carefully - Disk Utility will tell you which partitions will be deleted and which will not.

Then quit Disk Utility and set Macintosh HD as the boot volume and restart.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .