If I go  -> Sleep or even hold the power button, my Mac goes to sleep but when I go to wake it up I immediately see the screen I'd put it to sleep on. Before I was asked for my password again upon waking my Mac. I know that you can quickly tap a key after using the power button shortcut to prevent it going to sleep and you won't be locked out, but even after having my Mac in sleep all night last night and waiting a few seconds or minutes before attempting to wake it today I'm not prompted for my password which worries me because I have sensitive information throughout my Mac.

I have just deleted everything in ~/Library/Preferences/ in hopes it would fix bugs. Was that a mistake? Could that be the reason I'm having this issue? Should I go ahead and restore my machine to prevent other weird bugs which may have come up because of that?

  • 2
    Deleting EVERYTHING in ~/Library/Preferences is a bad idea. In System Preferences > Security & Privacy > General, do you have the "Require password [x seconds] after sleep or screen saver begins" checkbox checked?
    – IconDaemon
    Feb 18, 2015 at 18:02
  • That was the problem! Thanks. I had a feeling it was a setting neatly hidden away in System Preferences! I'm also never deleting all of ~/Library/Preferences again. Do you want to post this as an answer so I can close this question?
    – IIllIIll
    Feb 18, 2015 at 18:04

2 Answers 2


In System Preferences > Security & Privacy > General, make sure you've checked "Require password [x seconds] after sleep or screen saver begins":

enter image description here

In Sonoma (or earlier, perhaps, I can't remember) and later, the functionality has been moved to System Settings > Lock Screen > Require password...:

enter image description here

  • 5
    Any idea why this wouldn't work? It was working on the previous version of Sierra but after updating to 10.12.1 it no longer asks for a password. Sometime if I go into these settings and toggle it off and on again it works but does not persist forever. Seems like a pretty major security flaw.
    – steinybot
    Nov 1, 2016 at 19:21
  • 4
    @Steiny I had the exact same problem after upgrading 10.12.1. Doing the following fixed the problem. In System > Preferences > Security & Preferences, uncheck 'Require Password .. after sleep or Screen Saver begins." Put the computer into sleep for a while. Wake it up, go to the same screen and check 'Require Password .. after sleep or screen saver begins." Nov 6, 2016 at 7:52
  • 4
    I too had this problem in 10.12.3. Toggling “Require password” did not fix it. It persisted even after a reboot. I changed the “5 seconds” to “Immediate”, put the computer to sleep, and it worked. I was then able to change it back to “5 seconds” and it worked again. Preferences corruption? In any case this is a severe security vulnerability. There should be no way the password lock ever fails. Especially since you won’t know it failed until the next time you open your computer.
    – Nate
    Feb 19, 2017 at 1:39
  • 1
    @DilipRajBaral: Thank you. Your answer worked for me. Mar 24, 2017 at 15:45
  • Where is this option in Sonoma? Mar 7 at 22:27

Have you set the password timeout value in System Preferences?

 --> System Preferences --> Security & Privacy --> General --> Require password (x minutes) after sleep or screen saver begins

  • @icondaemon has already helped me with this and found this as the solution. Thank you for your answer!
    – IIllIIll
    Feb 18, 2015 at 18:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .