2

I'm in a group chat with 3 others. We all have iPhones. About a month ago, a new group chat was created with the same group. I deleted it, but it came back. 3 of the 4 of us experience this problem. The other guy has no idea what we're talking about when we say "this is driving me crazy."

Many others seem to have also experienced this problem:

"iOS 8 creating multiple group messages with same recipients" (Official Apple Forum)

There is no answer in the above thread.

How can we fix this issue?

7
  • 1
    I puzzled over this as well - I named my group and the name even transferred to the duplicate. Here's what my hunch is: received at address change. Compare your two groups by going into the info, and comparing each contact's blue highlighted contact item. I found one person's email was highlighted instead of their phone in one group. Let me know if you confirm this. Feb 18 '15 at 3:22
  • @bassplayer7 Each group has the same group members when I hit "Details" from within the group chat. Not sure what you mean by "blue highlighted contact item" - I don't think I'm seeing that. Feb 18 '15 at 3:47
  • Ok, I wasn't clear enough. We will assume your group consists of Sam, John, Bob, and you. Tap details in the group, and tap the circled "I" on Sam's contact listing. One of his contact items will be blue - either his email or phone. Make a mental note of that, and do the same for John and Bob. Then, go to the duplicate group and compare. I suspect you will find that at least one contact's info is different. Feb 18 '15 at 20:25
  • @bassplayer7 Very clear instructions. Thanks! Unfortunately all highlighted items are the same between the groups. Yikes. Not sure what to make of this, but I suspect it has something to do with "Bob's" phone, since he is the only guy who isn't experiencing this issue... any further help would be much appreciated. Feb 18 '15 at 22:16
  • Are the other ones in the group willing to cooperate? If so, ask each to go to Settings -> Messages -> Send & Recieve At, and narrow the options down to just one (whether a phone or email). Then wait and see. That would be the clincher on determining if that is the problem. Feb 19 '15 at 2:01
1

Make sure "group messaging" is turned on in settings. For some reason (maybe b/c i have hard and soft rebooted my phone a bunch) that option switched off.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .