8

I was trying to wipe the free space of an external USB 3.0 disk in OS X (Yosemite) disk utility. However, I receive the following error:

Disk Utility Error

EDIT: The disk is formatted as GUID / Mac OS Extended (Journaled) and 1.1 of 2.0 TB are occupied.

  1. Do you know what the cause / solution could be? Disk Repair returns no errors.
  2. Do you know of a terminal command to wipe free space?

Thanks!

  • What format? How full was it? – Tetsujin Feb 17 '15 at 12:39
  • @Tetsujin: see question update – n1000 Feb 17 '15 at 12:46
  • 2
    Does switching 'ignore ownership' on have any effect, from Get Info? [I'm still thinking in terms of 'permission to write' rather than 'broken'] – Tetsujin Feb 17 '15 at 12:50
  • @Tetsujin: Nice one. I didn't even know that option until I googled it. It is erasing right now. Do you want to add an answer? – n1000 Feb 17 '15 at 12:53
  • Cool. Glad it helped - let me cobble something together… ;) – Tetsujin Feb 17 '15 at 12:57
3

My first thought would be that it is a permissions error of some kind…

Either

  • the Drive is formatted as NTFS or ExtFS etc
  • The System doesn't have write permissions to the device itself

For the first, the simplest, if not cheapest solution would be something like Paragon NTFS or ExtFS or Tuxera NTFS

If it is a pure permissions/ownership issue, then for a removable drive the simplest fix would be to set it to 'Ignore Ownership' from the Get Info window. This should be sufficient to allow the system to write to the drive in order to securely erase.

3

If you run disk utility from the command line, you get the same behaviour with the following output:

# where `Title` is the name of the drive.
diskutil secureErase freespace 0 /Volumes/Title/

Started erase on disk1s2 Untitled
Creating a temporary file
Securely erasing a file
Creating a secondary temporary file
Mounting disk
Error: -69847: Couldn't create temporary file
Underlying error: 1: POSIX reports: Operation not permitted

You can fix this by running the command with sudo.

  • Unfortunately, the diskutil command with sudo generates the same error (just faster) – MikeB Apr 3 '17 at 14:52
1

I had the same problem. Restart, and while machine is restarting, hold down Command key and the R key simultaneously. Hold down until the Apple icon appears, then release both keys. Four options will come up-- choose Disk Utility. Continue with Erase Free Space procedure as usual.

First attempt worked for me, after 6 months of frustration.

Best of luck! Tim

  • I've had more luck with this method than running under a normal boot, but it still errors out most of the time. – duozmo Oct 23 '15 at 22:45
  • When I try this, then select my Mac HD, I find that the "Erase free space" button is disabled in the Disk Utility app. – MikeB Apr 3 '17 at 14:59
-1

I was attempting to erase free space on my laptop with mac disk utility and received the error message could not create temporary file and found the free space had been erased. Check about this mac, storage to see if free space was erased.

  • How do you know it erased free space? If the space was free to start with, what tool would you use to determine it had been correctly overwritten? – Tetsujin Dec 15 '15 at 6:20
-2

I had this problem / error message, but it turned out that Disk Utility HAD actually erased free space on the drive anyway.

  • How do you know it erased free space? If the space was free to start with, what tool would you use to determine it had been correctly overwritten? – Tetsujin Dec 15 '15 at 6:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .