3

I've finally figured out how to install Windows without any stray network connection errors or invalid .iso file errors, but I've run into a bit of an issue. The Windows partition doesn't have any drivers. Its' resolution is 640x320 and I don't even know if I can change that. I've downloaded the Boot Camp drivers for my machine (Late 2013 MacBook Pro 15" with Retina Display) and I'd installed the Windows-run partition with those drivers in the .iso, but somehow none of those drivers were installed.

I'd downloaded them again to my Macintosh HD partition, but I can't copy them to my Windows HD partition because of file system incompatibilities or whatever. At that point I'd decided to copy them to an NTFS flash drive, then copy them from that drive to my Windows HD partition, but I'm still not allowed to do that. I'm given the not-allowed cursor when I attempt to drag the drivers folder over. I'm pretty sure I can launch Setup.exe in Windows HD if I can figure out how to copy those files over and everything will be okay, but I can't figure out how to do that.

One last thing I'd tried (the first) was to connect to Ethernet via Thunderbolt to Ethernet adapter. This did not work and I'm assuming that's because I don't have an Ethernet driver, either. I couldn't even connect to the network.

I've never been through so much trouble just to play a game from The Sims series. Why can't they hurry to the release of a Mac version? :(

Thanks for reading.

Edit: Basically Boot Camp wouldn't allow me to create a bootable USB drive without some network error or claiming that I was trying to install from an iso which wasn't a Windows iso, when it was -- in fact -- a Windows iso. To avoid that I'd opened Microsoft's bootable USB creation tool (on my Windows-run server) to create the bootable USB drive on my flash drive. After that I'd copied the Boot Camp files over from the 'BootCamp5.1.5621' folder I'd downloaded from Apple's support site. I'd then chosen the following configuration in Boot Camp. My Boot Camp configuration After starting the operation my Mac had restarted and I was greeted with the 'Starting Windows' message. I'd installed Windows to the appropriate partition, then booted Windows to see that I didn't have any drivers at all.

I know it doesn't make much sense, but that was the configuration and my Mac did boot the new Windows partition properly.

Edit: I've found a workaround.

I've used my Windows 7 VM within VirtualBox to copy the files over after creating a shared folder to /Volumes/Untitled (Untitled was my Windows HD). I'd copied the files from my OS X desktop (also had a shared folder between OS X and the VM for my OS X desktop) which was where I had the Boot Camp drivers, then copied them over to the Windows HD disk. Now I'm going to boot Windows again and try to launch Setup.exe from the Boot Camp drivers folder. I'd still like a better solution, though. All answers welcome!

  • Did you use Boot Camp Assistant to prepare a thumb drive/partition your main drive/download drivers and finally install Windows 7? If not, please tell us how you did it exactly or better add it to your answer. – klanomath Feb 15 '15 at 20:27
  • No, actually. I've added a description to my question above. – IIllIIll Feb 15 '15 at 20:34
  • hmm so if i read that correctly "Remove Windows 7..." wasn't really successful. – klanomath Feb 15 '15 at 20:43
  • The description also says 'This allows you to add a Windows partition and start the installation process' so I'm thinking the title is misleading because that's exactly what happened after going through with it selected. – IIllIIll Feb 15 '15 at 20:46
  • Strange! The description is always the same but the header changes from "Install Windows 7 or later version" to "Remove Windows 7 or later version" after an initial partitioning of your main disk to prepare the Win7 install (and probably the actual installation of Windows). – klanomath Feb 15 '15 at 20:55
1

Probably your Boot Camp partition is hosed and couldn't be removed simply.

So i would try to reinstall Windows 7 with your pre-made (Microsoft's bootable USB creation tool!) thumb drive.

  1. Attach the Windows 7 installer thumb drive to your Windows server, format it if necessary (FAT32) and create the bootable Win7 install thumb drive again with the Microsoft tool.
  2. Download BootCamp5.1.5621 on your server
  3. Extract BootCamp5.1.5621.zip
  4. Copy the extracted files and folders ($WinPEDriver$, AutoUnattend.xml, BootCamp etc.) to the root of the thumb drive.
  5. The file/folder structure in the root of your thumb drive should look like this:

    root files and folders

  6. Detach the thumb drive from your server
  7. Attach the thumb drive to your Mac
  8. Reboot your Mac and immediately hold the alt/option button until you see the boot menu
  9. Choose your thumb drive as boot volume
  10. Try to reinstall Windows 7. You might have to reformat your existing Windows partition with the disk management tool of the Windows 7 Installer (don't delete or resize it!).

If that doesn't work reboot to Mac OS X, start Boot Camp Assistant and try to remove Windows 7 completely. If the removal fails check several answers here to remove your Boot Camp partition manually:
remove-windows-7
i-messed-up-the-fusion-drive (both require a Time Machine backup)
or some other answers here.

Before doing that post a comment and i will give advice depending on your partition layout.

Start Boot Camp Assistant from scratch to install Windows 7.

  • I'll try this. That's basically exactly what I'd done yesterday when I'd installed this, but I'm thinking it may help to uninstall through Boot Camp then reinstall through Boot Camp. Thanks! – IIllIIll Feb 15 '15 at 21:13
  • 55 minutes later I've tried this and I'm still where I started -- driverless. Now I'm going to try using Terminal to move the drivers over. – IIllIIll Feb 15 '15 at 22:09
  • That will not work if the thumb drive or win partition is NTFS formatted – klanomath Feb 15 '15 at 22:11
  • I just booted to a windows 7 Pro SP1 DVD to check. There is no erase option. What is shown is Refresh, Delete, Format, New, Load Driver and Extend. When you say Erase, I assume you meant Format. If Delete is selected, my guess is the MBR table will reflect this, but not the GPT table. Besides, one should never change the partitioning from Windows. – David Anderson Feb 15 '15 at 22:12
  • It didn't. I'm being told "No such file or directory" – IIllIIll Feb 15 '15 at 22:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .