Title says it. There is no "Invite People" link/button...

What setting do I need to change? Yes, I've got iCloud setup. Do I have to upgrade to the new iCloud storage?

Edit: more details: iPhone 5s. iOS 8. I think it's maybe because I have zero contacts in iCloud?

Edit: more details: When I create a new shared album, everything seems fine. I can add people to share with, or even delete the album. But the original album that prompted me to ask this question does not allow me to either add people to share with, nor does it allow me to delete the album. Something is special about it. Should all albums be equivalent, or is there a special use case for special albums that can't be shared nor deleted? The album name is "Family". I suppose the answer to my conundrum is that this album is specifically tied to people I add to my "Family". Not sure exactly how to do this but I suppose they also have to have iDevices.

  • Mac? iPhone? What OS?
    – Tetsujin
    Feb 14, 2015 at 17:24
  • Only the owner of the album (the person that created it) can invite people. Are you trying to share an album you created or someone elses?
    – Tyson
    Apr 9, 2015 at 20:54
  • @Tyson, it says "Shared by you".
    – Eddified
    Apr 15, 2015 at 21:12
  • Reading your last edit, do you have family sharing?
    – Tyson
    Apr 15, 2015 at 21:16
  • I had the same problem. The problem appears to be caused by having the word "family" in the name of the album.
    – user128222
    May 17, 2015 at 19:58

4 Answers 4


Per your second edit, it is indeed a special folder created by family sharing.

The whole family can contribute to the family photo album.

Now collecting and sharing family memories is easier and more fun. When Family Sharing is turned on, a shared album is set up automatically in the Photos app on all family members’ devices. Then everyone can add photos, videos, and comments to the album and be notified when something new is added. You can add or view photos and videos from iPhoto on your Mac, and from Photos on your iPhone, iPad, or iPod touch with iOS 7 or later.


I had this problem on an albums other than the Family album on a MacBook Air. It turned out to that the "To:" line was hidden whenever Photos.app was running on an external display. When I put Photos back on the laptop screen the control would re-appear.

  • I was having the same issue with my MacBook Air and Thunderbolt Display. As crazy as it sounds the To: field really is hidden. Check out the screen shots Thunderbolt and MacBook Air Mar 1, 2018 at 13:49
  • 1
    Nice catch Greg B!
    – Stu
    Jun 3, 2019 at 15:00

I can invite anyone to my shared albums whether they have AppleID or not just by typing their SMS or email address into the invite field.

I've seen the app freeze, so power off your iPhone and then try going back into Photos as soon as it restarts. If that doesn't work, post a screen shot of your attempt and I'll see if something else makes sense to try.


If it is titled Family, IOS only lets you add people who is listed under "Family Sharing" (settings>icloud>family>'Add Family member'). If you don't want to share everything you purchase from the App Store or iTunes store (which is what family sharing is all about), then create a new shared album with a new name. Then you can invite and do all those other things that sharing allows you to do.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .