I'm currently deploying "Network Link Conditioner" out to my web team. It's the latest version from the Apple Developer Website (October 16, 2014 from Hardware IO Tools) and I'm installing it on 10.10 and 10.9 partitions.

My issue is that I install it on my admin user and the rest of my users can't see the PreferencePane in System Preferences. Investigating further, only the root user and the user it was installed on can see the pane.

I've verified that it's in the /Library/PreferencePane (the root one, not the user one). I've tried installing it through the root user, through the admin user and through a custom user. I've tried adjusting permissions on the PreferencePane file itself. Nothing seems to be working

The install display says it's installing for all users, but it doesn't seem to be actually doing that. The worst part is if I try to reinstall it on another user, I get the error

"You can't install the "Network Link Conditioner" preferences. "Network Link Conditioner" preferences is installed with OS X and can't be replaced."

Any suggestions?

3 Answers 3


Ran into the exact same problem. Installed the Network Link Conditioner when my system had OSX Lion and XCode 4 or 5. Great tool but did not need it again until today. Found it no longer worked. My system now has OSX Yosemite and XCode 6.4 so I downloaded Hardware IO Tools for Xcode 6.3. Got the same message about not being able to replace it since it was installed together with OSX.

My solution was to first drag the tool from the opened .dmg onto the desktop and to then manually replace the tool using the command line:

cd Desktop
sudo mv /Library/PreferencePanes/Network\ Link\ Conditioner.prefPane Network\ Link\ Conditioner.prefPane.old
sudo cp -r Network\ Link\ Conditioner.prefPane /Library/PreferencePanes/
  • Worked great for me on Mac OS Sierra as well!
    – sm11963
    Commented Oct 17, 2017 at 16:53
  • 1
    Still working in 2022! Ran into this issue when trying to upgrade to Network Link Conditioner from XCode 14.1 additional tools. Sadly though it looks like nothing has changed... still a very buggy UI when you try to manage your profiles and your system is in Dark Mode. It's definitely abandonware from Apple.
    – Chris
    Commented Dec 7, 2022 at 4:30

I actually figured out what I did wrong and I wanted to record it in case anyone else ran into this issue.

The key for a setup like this is not to try and install it from anywhere but the Hardware IO Tool disk image. As soon as I did that, everything worked perfectly.

Previously, I had yanked the PreferencePane and deployed it with ARD, telling it to inherit the permissions of the root folder...and I'm pretty sure that's what messed it up.

  • For those looking for very explicit instructions, the steps would be: 1) Download adcdownload.apple.com/Developer_Tools/… 2) Open the dmg file and double-click the "Network Link Conditioner.prefPane" to launch the installer
    – mikegradek
    Commented Nov 30, 2015 at 8:41

Here is a more easy way. You can [option + right click] the icon in the System Preferences. Than click the "Remove the 'xxxx'" item. After that, just click the "Network Link Conditioner.prefPane" to install.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .