1

I'm experiencing issues sending iMessages from my Mac. It used to work, but stopped. I tried a bunch of "fixes" I found online:

  • sign out of iMessage and log back in another day
  • rebooting
  • restarting my phone

None of these worked to resolve the problem.

I tried to reset the Messages app by removing some .plist files, but that didn't work (those instructions are from 2012).

I'm running Yosemite 10.10.2. How can I reset the Messages app to a blank slate?

[EDIT Sat, Feb 14]

I also tried setting up Messages using another user account on my Mac, and it worked flawlessly. This leads me to believe there's some kind of issue with iCloud syncing between my iPhone and Mac.

2

I posted on the Apple Support Communities board for help. From the response I learned that removing ~/Library/Preferences/com.apple.imagent.plist clears some Messages app state. When re-launching it, I'm presented with a fresh sign in flow.

In my case, the root issue still wasn't resolved.

In Console.app I found log messages like the following:

2/16/15 3:23:18.011 PM identityservicesd[4905]:
  [Warning] SQLITE_CORRUPT encountered error 11 while accessing
  /Users/mike/Library/IdentityServices/ids.db, exiting!

Searching for that turned up another post on Apple's Support Communities board which suggested removing ~/Library/IdentityServices. This solved the issue I was having, and I haven't yet noticed any unwanted side effects.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .