1

I use Spotlight's Calculator feature occasionally, but I've noticed that it has stopped working recently. Instead I get a "No Results" message:

Example calculation not working

I've verified that Calculator is enabled in Spotlight System Preferences. Restarting the computer does not help. I also tried disabling and re-enabling the Calculator setting in Spotlight.

Any other ideas?

  • did you try with 0.1 instead of .1 – Ruskes Feb 12 '15 at 21:52
  • Just tried, same problem. Also a problem with just 33*44 – Dolan Antenucci Feb 13 '15 at 1:36
  • Any chance you've deleted the calculator app? (Not sure if it makes a difference, but might as well look into it.) – user24601 Feb 13 '15 at 15:18
2

Delete the spotlight preferences file:

~/Library/Preferences/com.apple.Spotlight.plist

And then reboot. I was having the same problem and that fixed it for me.

  • A day later, with no system changes on my end, the spotlight calculator stopped working again. Have you had similar behavior on your end? – Dolan Antenucci Feb 18 '15 at 1:43
  • I ended up calling Apple Support; their solution was to reinstall my operating system. Good times! – Dolan Antenucci Feb 18 '15 at 2:40
  • No, mine's been working for about a week now. I hope it stays that way. – Jonathan Potter Feb 18 '15 at 7:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .