4

Every SSH connection exits with an abnormal code.

For example

ssh corti@myhost.example.com true

results in

Feb 11 10:16:47 mac-mini com.apple.xpc.launchd[1]: (com.openssh.sshd.163F2BE0-40C6-4B17-AB4E-5A0A07A524DE): Service instances do not support events yet.
Feb 11 10:16:48 mac-mini.home sshd[35674]: Accepted publickey for corti from ***.***.***.*** port 65030 ssh2
Feb 11 10:16:48 mac-mini.home sshd[35676]: Received disconnect from ***.***.***.***: 11: disconnected by user
Feb 11 10:16:48 mac-mini com.apple.xpc.launchd[1]: (com.openssh.sshd.163F2BE0-40C6-4B17-AB4E-5A0A07A524DE[35674]): Service exited with abnormal code: 255

Why is sshd exiting with a non zero return value (i.e., 225)?

  • 3
    I know this is old, but did you ever figure this out? I'm troubleshooting a nighttime problem with rsync and I've noticed that all of my launchd/sshd sessions on the server end with "abnormal code: 255". – tim.rohrer Aug 21 '16 at 17:20
  • I think I've found the solution. Checkout unix.stackexchange.com/questions/461851/… – pkgajulapalli Aug 13 '18 at 1:57
3

In recent macOS versions, the rotten fruit geniuses have restricted SSH access to admin users only. I was having this 'service exited with abnormal code' issue and I fixed it by Preferences -> Sharing -> Remote Login: On and 'Allow Access to': All Users (or the users/groups you want). You must be an admin to do that (you must be able to unlock the locker icon on the bottom left).

Two hours wasted, damn idiots...

  • 1
    That's not the problem I describe. The SSH login is working. It's result code of the ssh binary that always return 255. I have no problems with the connection – Matteo Jul 6 '18 at 15:52
  • Exactly, I could connect and pass the password challenge and then the client got 'Server closed connection', while the server was logging 'exited with abnormal code 255'. You might have another problem, but I had the same symptoms and I fixed it the way I said. – zakmck Jul 6 '18 at 16:18
  • 2
    But in my case the connection is successful: it’s only the code that is wrong. – Matteo Jul 6 '18 at 16:19
  • 1
    You mean you can login and start a sesion anyway? I couldn't. – zakmck Jul 6 '18 at 16:20
  • 2
    Yes exactly. It’s only the return code. – Matteo Jul 6 '18 at 16:42
-1

Make sure that your user corti has Remote Login feature enabled in Sharing Preferences.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .