3

After upgrading to 10.10.2 when I lunch a GUI app from a terminal using open -a app the app doesn't see the path currently set from that terminal session. Before the upgrade that was working. Any idea what happened?

  • Have You tried this: apple.stackexchange.com/questions/152294/… ? – Mateusz Szlosek Feb 11 '15 at 12:37
  • As he stated in a deleted comment in that thread : Apparently it does not work anymore in 10.10.2 – Matthieu Riegler Feb 11 '15 at 12:42
  • No idea why my comment is deleted ... I've tried it, it doesn't work. – Nenad Dordevic Feb 11 '15 at 12:52
  • This is a known bug in 10.10. launchctl setenv can't set the $PATH. /etc/launchd.conf is deprecated and no longer works either. What app are you trying to set the $PATH for? I can try a few things later when I'm back at my Mac. – TJ Luoma Feb 11 '15 at 18:11
  • WebStorm/IntelliJ, I have a workaround for this to get Grunt working and some commands in embedded Terminal, but it used to be much easer to pick up everything from Terminal ... – Nenad Dordevic Feb 11 '15 at 20:35

You must log in to answer this question.

Browse other questions tagged .