1

Screen sharing between my iMac and my Mac Mini stopped working after I applied the 10.10.2 update. I'm trying to access the Mac Mini from the iMac. I get the standard error message advising that I should check the Mac Mini is on the network etc. etc.

File sharing works well. I can copy files between the two Macs and can move and delete files on the Mac Mini. I always access Screen Sharing using the same user credentials as for File Sharing.

Things I have tried:

  • Turned Screen Sharing off then on again on the Mac Mini.
  • Checked the IP address many times.
  • Invoked Screen Sharing using the application (in CoreServices), the Connect to Server dialog (command-k) and the Network dialog (command-shift-k).
  • Reinstalled 10.10.2 using the combo updater.
  • Adding port 5900 to the vac command (i.e. vnc://nnn.nnn.n.nnn:5900).
  • Deleted the screen sharing prefs files (on the iMac).
  • Deleted relevant entries in my KeyChain (in the hope SS would pop a login dialog - but it didn’t).
  • Made sure the Mac Mini is awake.
  • Checked logs but can find nothing at all on Screen Sharing.
  • Installed the ARD update on both machines.
  • Checked Firewall settings - Screen sharing is specifically allowed (and there are no other sharing functions blocked).

My Mac Mini does appear under “Sharing” in the sidebar of the iMac's windows suggesting (with the working file sharing) that this is not a networking issue.

The iMac is connected to the router by cable; the Mac Mini is connected by wifi.

Screen sharing worked under 10.10 and 10.10.1. Now it doesn't. I haven't played with settings except as stated above.

Does anyone have any ideas ? This has me totally stumped.

Many thanks.

Garry

4

After working with Apple, I have an answer. It looks like the 10.10.2 update changed your firewall settings. Try this:

System Preferences>Security and Privacy>Firewall Options

Scroll down the list till you find "screensharingd". If it's marked as block in coming connections, change it to allow incoming connections.

Be sure to reboot your computer and you should be good to go!

  • Yes, many thanks. This solved my problem. Cheers. – Garry Feb 20 '15 at 3:42
  • You may want to mark it as answered for others who have the same issue. – bjbk Oct 8 '15 at 2:00
  • Same problem. But the firewall is disabled both on my Mac Air (from which I'm trying to connect) and my Mac mini (to which I'm trying to connect). – PKHunter Dec 6 '15 at 6:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .