1

I have tried many a thing to solve this matter. Long and short of it is I am getting the standard "connection timeout error" but only on some networks (which are successfully connected to by other Apple devices).

What I have done (after extensive reading) and things worthy of note:

  1. More power cycling than I can count. Both of Wi-Fi and computer.
  2. Creation of new places with various changes or not changes in Network preferences. Manual resetting of DHCP Lease or adjusting of MTU's as per other suggested fixes.
  3. Deletion of SSID related files in the Keychain.
  4. Deletion of network configurations as per other recommendations.
  5. Reset NVRAM.
  6. Fresh install(s) of Snow leopard (x2) and Lion(x2).
  7. Checked religiously for updates on software.
  8. Used Network Diagnostics, Assist Me, and Join other network (Both with attempts with accurate password and inaccurate. The dilemma seems to be that it won't successfully make contact to my home Wi-Fi, even to tell me if the password is correct).
  9. Wi-Fi works almost everywhere but my home (regardless of how close my computer is to the station or if all other nearby devices that can cause interference are off).
  10. Did not have this issue with Snow Leopard 10.6.0, but became an issue upon an update (which is required for any form of computer use that involves the internet as I discovered as every file out there required the highest end of the operating system to be used, such as Flash or Java).

My computer is a late 2007 MacBook that cannot run an OS higher than Lion.

  • what router are you using and whos ISP ? do you have a application that would "mange" your WiFi, like little snich or other ? could you publish your connection by holding alt and clicking on the wifi icon! what are the "some networks" ? – Ruskes Feb 10 '15 at 20:05
  • I'm afraid that the router is my landlord's, so I do not have that information readily available. The application in question for managing my wifi is exclusively the apple OS. I don't have any security features enabled just to make it easier. And some networks appear to include a couple WPA2 password enabled ones, but not others. Case in point, I am at a coffee shop right now which uses the same. – Adam Feb 10 '15 at 20:12
  • The info I obtained by doing that key combination you suggested gave me the following data bout my present connection: PHY Mode:802.11n Bssid:00:1c:b3:ae:f3:1d Channel 11 (2.4Gz) Security wpa2 personal Rssi -62 Transmit rate 13 mcs index 2 – Adam Feb 10 '15 at 20:15
  • ok, do the same (alt+wifi) when at home and compare. Also check if it is loss from computer to the router or from router to the world. Since I do not know if Lion has it, check if you have the "Network Utility" in the /System/Library/CoreServices/Applications if yes use it to run the ping test. – Ruskes Feb 10 '15 at 20:36
  • I'm afraid that I cannot do that test at my home wifi - as it cannot establish a connection to it whatsoever. As for the ping test - I do not appear to be able to do that (presuming of course it is fairly obvious where it would be found in the network options). – Adam Feb 11 '15 at 18:15
1

OK, lets try to Manually connect to your WiFi.

Use following in your Terminal app (located in the utility folder).

Turn On (skip this if it is on already)

networksetup -setairportpower en0 on

Find (skip this if you know the WiFi name and the passowrd)

/System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Resources/airport scan

Connect

networksetup -setairportnetwork en0 WIFI_SSID_I_WANT_TO_JOIN WIFI_PASSWORD

Just replace the "WIFI_SSID_I_WANT_TO_JOIN" with your WiFi name

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .