1

I have a Dell monitor connected through a thunderbolt port.

Sometimes my Mac for some reason is attempting to play audio through that port. How do I stop this from happening?

It appears in my list of sound outputs in system preferences but I have headphones selected. Unplugging the monitor from the thunderbolt port makes the audio work correctly.

  • It thinks you have a Video+Audio device (like TV) plugged in :) do you ? what does it say for what is plugged in? – Ruskes Feb 9 '15 at 17:32
  • 1
    I found the issue. I was using GarageBand and it has it's own setting for audio out separate from System Preferences. – Berry Blue Feb 12 '15 at 3:33
  • nice job, make it a answer ! – Ruskes Feb 12 '15 at 4:04
1

Same thing happened to me. You have to manually change it in System Preferences > Sound > Output Volume.

1

Alt-click the audio item in the menu bar and select the proper source.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .