0

I have a problem with ethernet connection on my ATV3. It started about one month ago. ATV randomly drops ethernet connection for a two seconds. Here is the screenshot from my router:

ATV connection screenshot

  1. I'm already check the router interfaces and cable, other devices working fine without any problems.
  2. I have enabled autoupdate on ATV and the latest firmware installed.
  3. Also I tried to downgrade the speed/duplex on interface to 10 megabits half-duplex.

Is there any recommendations or solutions?

  • Did your issue coincide with a firmware update (possibly the 7.0.2 version)? We've had a handful of Apple TVs that have exhibited issues with Ethernet connections since this update. Restoring the unit through iTunes is the only way we've found to restore normal function. – ScunnerDarkly Feb 9 '15 at 11:21
  • I'm tried to restore it. It works normally until first sleep. When it wake up after the behaviour still the same. – SimWhite Jun 13 '15 at 9:57
1

I had problems with my ATV3 similar to yours. Went away after I've setup the ATV to take a manually assigned IP, and reserved that IP on the router (Time Capsule) for this ATV (by Mac address). Problem gone ever since.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .