1

Grabbed out my old unused White Macbook 13" Mid 2009 (Macbook 5,2) because I'd like to donate it to someone. However, it wouldn't power on or charge (no light on the MagSafe adapter).

I worked out that if I first connect the MagSafe adapter to another Macbook (a 13" Macbook Pro) and then plug it into the 13" White Macbook the green light turns on with White Macbook 13". So it would seem that the White Macbook isn't completing the handshake but the MagSafe adapter works for a while after the handshake is completed on another Mac. This is all 100% reproducible.

Anyway, the Macbook still wouldn't turn on (and the MagSafe indicator remains green - never orange). So I worked out that if I SMC reset, the Macbook will then proceed to boot. However, when booted it said "No battery connected" and the fans remain on high power constantly (i.e. the kind of stuff an SMC reset is supposed to fix).

If I turn the computer off it then won't boot again. I have to repeat the procedure i.e. MagSafe handshake with another Mac, then SMC reset and it boots.

I pulled apart the Macbook detached the MagSafe connector and cleaned some gunk off it. I then replaced the hard-drive with a brand new SSD that has Yosemite installed (instead of Lion). I then gave everywhere else inside and out a clean and reassembled. However, after reassembling the same problem persisted (SMC reset needed before booting).

After several SMC resets and boots, I've now got the Macbook in another state. The power is connected but there is no light at all on the MagSafe. However, the computer boots up. When booted fans are on again, but no power indicator of any sort is in my status bar (no battery, no DC power thunderbolt either). Disconnecting the power instantly turns the Mac off, so clearly it's really running off DC power.

The Macbook is running the latest firmware/SMC. When booted up everything actually functions fine aside from the fan - I'm typing on the Mac now.

Does anyone have any suggestions as to what could be wrong, tests to diagnose or ideally a solution? I'm reasonably handy with a multimeter so if anyone has some power diagnosis steps then I can follow along easily enough.

Update:

The process I was using to get the machine to boot was a bit flakey, however I've now narrowed it down to 100% reproducible sequence.

  1. Disconnect power cable.

  2. Hold the power button on Macbook - Duration is not important, you can move to step 2 in a matter of milliseconds.

  3. Connect the power cable whilst still holding the power button.

  4. With the power cable in, keep the power button held for at least 5 seconds.

  5. Release the power button.

  6. Press the power button to boot the Macbook.

Note: Having another Macbook around to plug the cable into is not important - all that seems to do is ensure the MagSafe light comes on, but it boots fine with the light off.

Now, when booted I have the fan and battery symptoms listed above.

Update 2:

I took the top off again and shorted the "SMC RST" (SMC Reset) pins on the board. This didn't resolve the problem, the behaviour remains the same. However, I've noticed a very faint ticking noise when I first connect the MagSafe cable to Macbook. It's very quite but there are exactly 8 ticks evenly spaced over about 2-3 seconds. This is pretty odd as the only moving part in the whole thing is the fans. Yet I hear this 100% reproducibly when I connect the power cable.

Update 3:

I'm presently waiting for a new battery I've ordered to arrive. Hopefully the new battery will shed light on the issue, or ideally resolve it!

Update 4:

Brand new battery has arrived. When I insert the battery and try boot, the machine will not boot. My usual boot process (outlined above) does not work with the battery present, I can not power on at all. The Magsafe connector's light remains off.

The machine continues to boot post SMC following the procedure above when the battery is not present. If I then insert the battery after the machine has booted, the laptop stays on. However, OS X thinks no battery is there. If I remove the power cord the laptop continues to "function" (i.e. full-speed fans) using the battery. However, there is no indication that the battery is being used in OS X, and when the cable is inserted there is no indication that it is charging (the Magsafe light remains off).

  • Literally everything aside from turning on normally, charging the battery and the high fan speed seems to be working fine, even sleep mode. – Benjamin Dobell Feb 9 '15 at 10:25
  • Sounds like there could be a problem with either the logic board or the MagSafe board since both of these parts are responsible for charging your battery and giving it power. It could be that the battery charging/sensing circuitry has gone bad. – Flying Trashcan Feb 26 '15 at 14:44
  • @FlyingTrashcan I absolutely agree, however ideally I'm after a technique to help me diagnose precisely which circuit is at fault. – Benjamin Dobell Feb 26 '15 at 14:50
  • Having same exact Issue with a mac a1286 Disconnect power cable Hold the power button on Macbook Connect the power cable whilst still holding the power button With the power cable in, keep the power button held for at least 5 seconds. Release the power button. Press the power button to boot the Macbook. mac boots fine with high sped fan, no light on magsafe charger. If i plug in the charger the light turns green and it will not boot. and will not turn orange to charge battery. tried resetting nv ram, no fix – MAINE NORTHERN LIGHTS Dec 4 '16 at 22:37
4

Historically, Macs have been known to have various issues - including not starting up - when the PRAM battery has died. Later MacBooks (including yours AFAIK) use the main battery for PRAM and SMC memory retention rather than having a separate battery for this purpose. Replacing the battery should clear startup and charging issues.

  • 1
    Do you have any references to back this up? It seems strange to me given that you can actually boot and use Macbooks (older ones with removable batteries) without a battery in the bay. – Benjamin Dobell Feb 9 '15 at 10:23
  • Reference link added for you. You will find virtually ALL laptops of all makes will run fine without a battery, it would be a poor design that wouldn't let you run on AC power alone. Not sure why you'd want to though, I didn't mention running without a battery. I did however mention replacing it which should restore your MacBook's functionality. – ScunnerDarkly Feb 9 '15 at 11:08
  • thanks for adding a link. My point was that failing Macbooks, this one included, tend to exhibit the failing behaviour regardless of whether or not a battery is present. If PRAM and SMC retention were reliant on the main battery being present then functional Macbooks wouldn't boot properly without a battery present. So based on that logic I don't see how replacing the battery could resolve the issue (given a battery isn't required at all for a Macbook to function). - Note: This is speculation, but based on the information at hand I believe my logic makes sense. – Benjamin Dobell Feb 9 '15 at 11:59
  • It's not always the case that a failed or failing PRAM battery will cause issues, but it is a well known cause in those situations where a Mac completely fails to start. Macs with a failed PRAM battery generally do start up ok, although OS X will alert you to the system time and date being incorrect, once booted. As mentioned, portable Macs used to have a separate battery for PRAM retention but this changed with the move to unibody construction. Unibody users can't easily run without a battery, so again not an issue (more...) – ScunnerDarkly Feb 9 '15 at 12:19
  • Yours is one of the very few "inbetween" models that doesn't have a separate backup battery, instead relying on the main (user-removable) battery for everything. So, most portable Mac users either have a PRAM backup battery (older Macs), or don't have the option to easily remove their battery (newer Macs), so PRAM and SMC (or PMU on PowerPC systems) are nearly always receiving enough power to retain their settings - from practical experience, not speculation. Anyway, once you've reset the SMC controller, does everything work properly and stay that way as long as you don't disconnect AC power? – ScunnerDarkly Feb 9 '15 at 12:22
2

Just to make things clear. Here is a picture of a logic board for a MacBook (13-inch Late 2006/Mid 2007).

enter image description here

The round blue thing is the Backup Battery. Next picture shows the battery being pried up.

enter image description here

These pictures were taken from page 136 of the following Apple Service Manual:

Service Source
MacBook (13-inch)
MacBook (13-inch Late 2006)
MacBook (13-inch Mid 2007)

You can get a copy of this manual as a pdf by downloading this linked file: MacBook Late 2006/Mid 2007. The Apple Service Manual for your Mac is:

Service Source
MacBook (13-inch, Early and Mid 2009)

You can get a copy of this manual as a pdf by downloading this linked file: MacBook Early and Mid 2009. At the top of page 10, is the following:

enter image description here

So there is a capacitor to provide power in the event the main battery has been disconnect for short periods of time.

By the way, you might find the latter service manual useful. It is a shame most of the links are broken. I tried looking at the manual, but without the computer in front of me, it is hard to run some of the tests.

  • 1
    Thank you very much for the response, I do have the service manual already, but the links are appreciated nonetheless. However, I'm not quite sure what you're suggesting the problem is. Are you suggesting I need to replace the backup battery? – Benjamin Dobell Feb 26 '15 at 9:54
  • Hi Benjamin, sorry to hear the new battery hasn't cured the issues. This is looking very much like an SMC problem, possibly corrupt SMC firmware - take a look at support.apple.com/en-us/HT201692 and see if you get any joy there. – ScunnerDarkly Mar 2 '15 at 9:57
  • One other thing, the Apple Service Diagnostic utility for your machine is ASD 3S132 - ASD utilities aren't available to the public but can be found on the internet if you look hard enough. ASD will give you more detailed information on your hardware than the diagnostics supplied on the Applications Install disc that would have originally been supplied with your MacBook. – ScunnerDarkly Mar 2 '15 at 10:02

You must log in to answer this question.

protected by bmike Dec 5 '16 at 0:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .