I am on Mavericks and I am running emacs 24.4.1, but I have the same problem also with 22.1.1. When I open mac on a terminal on the remote host, it does not recognise option key (alt) like the meta key. I have modified the .emacs in the following way

 (setq mac-option-key-is-meta nil
       mac-command-key-is-meta t
       mac-command-modifier 'meta
       mac-option-modifier 'none)

this should change the meta key to command, but also in this case the meta key doest work . This only work on the X version of emacs (when I open emacs in a new window), both with the option as meta key that as command as meta key. This is a problem I have with emacs in the terminal-only.

Now I don't know how to run commands in emacs! is there any keybinding I can use?

up vote 6 down vote accepted

I had this problems some time ago. Turns out your Terminal app is configured to not use option as meta key. I'm running Mavericks and this is the default setting.

All you have to do is open your Terminal app, click on the Terminal > Preferences > Settings > *Whatever profile you use* > Keyboard, mark the option "Use option as meta key"

  • Use left option key as +Esc worked for me. – oozzal Feb 5 '16 at 5:18

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.