0

I've a MBP with OS X Yosemite & I want to remotely connect with other Macs over internet, primarily for troubleshooting purpose. I currently use TeamViewer but I'm not satisfied with it.

  • Good idea. What is the question / the problem when connecting? – n1000 Feb 7 '15 at 12:38
  • @n1000 CMD+K - Connect to Server - I put the Server address in this format 'vnc://xxx.xxx.x.xxx/' - It says connecting for a while & then the error: 'Connection Failed' Please make sure that Screen Sharing (in the Sharing section of System Preferences) is enabled on the computer to which you are attempting to connect. Also make sure your network connection is working properly. [I've enabled the Screen Sharing option from System preferences & enabled 'Allow access to All users' & so did the other party to which I wanted connect with] – Satyajeet Feb 9 '15 at 10:58
  • This might be a firewall issue. Did you check if you can reach the remote computer's port 5900? This link might help you. – n1000 Feb 9 '15 at 20:04
1

Did the other side have the 5900 port open? Every machine you want to connect using screen sharing must be in a network with this port open.

Did you tried Messages app feature to do it? You just need to select a contact, click on Details and Ask to Share Screen.

enter image description here

Once approved in the other side, you can see the other screen. And you can talk with the other side if you want.

To control the other screen, from the other side must select the connection icon and allow you to control it.

I used to have installed Team Viewer until I discover this functionality.

  • I'll try Using this Messages feature & update you. About the 5900 port, how do I my partner open it ? [I've enabled the Screen Sharing option from System preferences & enabled 'Allow access to All users' & so did the other party to which I wanted connect with] – Satyajeet Feb 9 '15 at 11:05
  • I tried 'Ask to share screen' from Messages app, & again the same error: Please make sure that Screen Sharing (in the Sharing section of System Preferences) is enabled on the computer to which you are attempting to connect. Also make sure your network connection is working properly. – Satyajeet Feb 10 '15 at 9:45
  • Well, is Screen Sharing enabled on the other Mac? (System Preferences > Sharing > Screen Sharing) – Chris Jul 11 '16 at 21:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .