1

I know this discussion about spell checkers for Pages, here. I am searching for the files ending with .aff or .dic. Without them, you cannot use them in system. My current OS X is Yosemite 10.10.2.

The manual of OS X says that in Settings > Keyboard > Spelling > Set up ...

To add an additional spelling dictionary, copy the dictionary files (.aff and .dic) to the Spelling folder in your Library folder.

Is there any standard dictionary for Finnish?

  • Yes. Not correct format. – Léo Léopold Hertz 준영 Feb 7 '15 at 19:50
  • @TomGewecke It may be possible to those file types. The next thing remains to consider creating them from some existing filetype. I contacted the administrator of the project about the creation of the specific fileformats. – Léo Léopold Hertz 준영 Feb 8 '15 at 6:23
  • Just simply: Without the two supported fileformats, you cannot get system wide spell checker. – Léo Léopold Hertz 준영 Feb 8 '15 at 15:52
  • @TomGewecke Spell checking of OS X. – Léo Léopold Hertz 준영 Feb 8 '15 at 17:31
1

The Finnish language is not like others and the spell checking is more complicated than just .aff/.dic files. As Tom wrote, the solution is to use Voikko project's VoikkoSpellService (osxspell) which creates system wide spell checker for Finnish.

It works also on OS X Yosemite but the /Library folder is hidden and you have to make the Services folder if it doesn't exist. The readme in explains the rest steps to make it work.

  • I created the folder /Library/Services. Moved the app there. Logged out and in again. Started the app my from the folder by right clicking and open. I started TextEdit. My test data "A book is on table. Kirjae on pöydällä. Kirjava koira haukkuuu. " It does not recognize the typos in TextEdit and not now here in Google Chrome when typing this comment. – Léo Léopold Hertz 준영 Feb 8 '15 at 21:25
  • @Masi Did you set the dictionary to Suomi in Edit > Spelling and Grammar > Show Spelling and Grammar? Did you check the options for spellchecking in that menu? See the new graphic in my answer. – Tom Gewecke Feb 8 '15 at 22:49
  • 1
    @walokra /Library is not hidden. That's user/username/Library. In any case, there is no reason not to put this in system/library/services, which is not hidden and already exists. – Tom Gewecke Feb 8 '15 at 22:53
  • @TomGewecke I do not have Spelling and Grammar in Settings -page. I check nothing. – Léo Léopold Hertz 준영 Feb 9 '15 at 8:01
  • @Masi It is not found in "Settings". I am talking about the Edit menu in TextEdit and other apps. – Tom Gewecke Feb 9 '15 at 12:52
2

Download Voikko spell for 10.8-9 from

http://verteksi.net/lab/osxspell/

and put it in System/Library/Services (not Library/Services or Home/Library/Services)

Go to Edit > Spelling and Grammar > Show Spelling and Grammar and set the dictionary to Suomi (not Automatic).

Also in Edit > Spelling and Grammar, check the items for checking and correcting spelling.

You should then see, for example in TextEdit, something like

enter image description here

  • This does not work in Yosemite. I cannot move the app to the folder /Library/Services because it does not exist in Yosemite. I will contact the current developer about this issue. – Léo Léopold Hertz 준영 Feb 8 '15 at 20:19
  • 2
    It's NOT /Library/Services, but System/Library/Services, as I said. Please look more closely – Tom Gewecke Feb 8 '15 at 21:38
  • Just a note, I had to restart my machine for the dictionary to become available. – tommyf Jul 2 '15 at 6:30
  • The Finnish instructions indicate "user /Library/Services" and not "System/Library/Services" and then in the next line "~/Library/Services/..." a bit of a mess but I think the "System/Library/Services" is the correct one and works for my wife on 10.10.2, no restart was required but logout/login was done after each step. – KalleMP Sep 6 '16 at 11:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .