When trying to ssh into a remote OS X machine, I get:

ssh: connect to host … port 22: No route to host

ping or traceroute do not reach the machine either.

The interesting detail is that if someone is logged onto the machine as a guest, then the machine is reachable and it can be pinged.

Is it possible to have the machine always be reachable through the network? I have looked for information on the web, but while many pages describe how to enable remote access, I did not find any one that addresses the problem above.

(If needed, I can have someone log directly on the Mac onto my (Administrator) account. Maybe ssh works too when the guest is logged in, I was not able to try yet, as I only have a remote connection.)

  • 1
    Did you check the "sleep" settings ? – Kent Feb 7 '15 at 7:00
  • Good question. :) Normally it never sleeps, but I'll have this checked anyway. – Eric O Lebigot Feb 7 '15 at 7:52
  • @EOL Did you enable FileVault on said Mac? – klanomath Feb 7 '15 at 7:57
  • @klanomath I think I did (as far as I remember: I was last on this Mac a year ago). – Eric O Lebigot Feb 7 '15 at 10:50

Probably FileVault2 is enabled on the remote Mac.

After a clean reboot and before entering the FileVault/user password the disk won't be available and subsequently the common network won't be enabled.
After unlocking the disk locally you should be able to discover your Mac and ssh to it.
If the Guest account is enabled in the FileVault mode your Mac might be pinged depending on the network setup (DHCP), but since it is a special 'Safari window only mode' you shouldn't be able to ssh to it.

To reboot a FileVault-enabled Mac remotely enter sudo fdesetup authrestart. This allows you to restart a FileVault-enabled system without requiring an unlock during the next startup. Check this Apple support page for more information.

If FileVault2 isn't enabled i would expect that the sleep and Wake-on-LAN settings aren't properly set.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .