0

I'm sending a Mail message with text that looks like a link. I've color-coded this text, and I don't want it transformed into an underlined blue link. How can I stop Mail from "linkifying" my text when I send it?

Note: I know that I can right-click on a link and select "Disable Link", but unfortunately 1) these links don't show up until the email is sent, and 2) disabling the link doesn't seem to change how it displays the email when it is received.

I did a test with the word link.google.com and this is what the raw source looks like after sending:

--Apple-Mail=...
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html;
    charset=us-ascii

<html><head><meta http-equiv=3D"Content-Type" content=3D"text/html =
charset=3Dus-ascii"></head><body style=3D"word-wrap: break-word; =
-webkit-nbsp-mode: space; -webkit-line-break: after-white-space;"><a =
href=3D"http://link.google.com">link.google.com</a>
1

Switch off... Edit > Substitutions > Smart Links.

enter image description here

|improve this answer|||||
  • This was a good idea, but didn't really work. I disabled substitutions and then sent a test to myself -- it came back with the hyperlinked text still. – AmadeusDrZaius Feb 6 '15 at 17:51
  • There's always the possibility it's being 'smart' after the fact. You could always switch to plain-text - Prefs > Composing – Tetsujin Feb 6 '15 at 18:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .