4

I'm on Yosemite (10.10.2). Since upgrading I got some DNS issues, it seems my loopback isn't working any more. When I'm talking to my app locally via http://localhost:port, localhost in some cases (sorry for being vague here) gets resolved to my current local IP. (observed with rails and openstack)

some analysis:

mac:~ me$ scutil -r localhost
Reachable,Local Address,Directly Reachable Address
mac:~ me$ scutil -r loopback
Not Reachable

etc/hosts:

127.0.0.1   localhost
255.255.255.255 broadcasthost
::1             localhost 
fe80::1%lo0     localhost

etc/networks:

loopback        127             loopback-net

And a maybe related issue: DNS sometimes stops working completely. The only thing that helps, is a force quit of the discoveryd process.

I appreciate any help guiding me in the right direction to solve this issue. Thanks in advance.

2
  • Have you been able to find a solution to this?
    – Arnold
    Apr 19, 2015 at 10:37
  • My workaround is to always use 127.0.0.1 instead of localhost, luckily that was configurable everywhere I needed it.
    – Carthaca
    May 19, 2015 at 10:28

1 Answer 1

1

This might possibly be not the best long-term solution - I can't fully test as I don't actually have active IPv6 from my ISP yet, only on my local network.

I simply set my hosts file to

127.0.0.1   localhost
255.255.255.255 broadcasthost
::1             127.0.0.1 
fe80::1%lo0     127.0.0.1

which has so far given no noticeable issues.

1
  • Thanks for the suggestion, but well this does not solve the loopback issue: mac:~ me$ scutil -r localhost Reachable,Local Address mac:~ me$ scutil -r loopback Not Reachable so the only thing that changed is, that localhost isn't a 'Directly Reachable Address' any more
    – Carthaca
    May 19, 2015 at 10:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .