2

I have a Macbook Pro running OS X Yosemite 10.10.2. My university uses a captive portal to connect via Wi-Fi. I was able to connect and log in just fine, but after I updated from 10.10.1 to 10.10.2, I can connect and get a valid IP but I cannot access the log in page through the captive portal. When I try to display the log in page from the browser (I have tried Safari, Firefox and Chrome) the result is the same. I get the server not found error on the browsers and the website couldn't be loaded error on the captive portal.

I am able to connect and login to the network using my iPhone and I can connect to other networks from my Mac. Manually deleting the network configuration files and resetting DNS did not work.

I hope there is a way to fix this. Thanks in advance.

ps. I use a MacBook Pro with Retina display, OS X Yosemite (10.10.2), 15-inch, Early 2013

  • I need an answer here too – Simon H Feb 5 '15 at 17:39
2

I found a solution to the captive portal problem with 10.10.2...

  1. Connect to the internet via iPhone and USB cable.
  2. Now also connect to the wifi network with the captive portal. Change the default route to use the wifi.
  3. Now the laptop uses the phone for DNS requests, but routes other traffic via the wifi interface.
  4. Authenticate on the captive portal page.
  5. Unplug the phone and restart the wifi.

With a bit of luck the captive portal should remember you and you should be able to use just the wifi interface.

My best guess is that the DNS setup process fails (no /etc/resolv.conf file) when the captive portal firewall is not letting traffic through. OS X probably does some test to see if it's on the internet (probably tries to reach a URL like captive.apple.com) and if this fails then it just stops setting up the DNS system).

  • Even when I'm connected via iPhone, I don't seem to connect to the authentication page of the captive portal. But you are right, it checks if I am connected by trying to reach a URL, then it can't connect. – begozcan Mar 16 '15 at 9:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .