8

I'm trying to export all emails from an account I have setup and mapped to Apple mail on my computer. There are 1200 emails. The account is no longer active so i'm trying to export all the emails in the mailbox in apple mail to an .mbox file that I can import somewhere else.

The problem is when I do an export of the mailbox and then import it somewhere, there are only 88 emails when there should be 1200+.

Why is this only exporting some of the emails and how can I make it so it exports all of them?

  • Export with what, from where, to where? – Ruskes Feb 5 '15 at 4:38
  • Trying to export via the Mail app by selecting a mailbox and going to export mailbox. I'm then trying to import it into thunderbird for now just to verify that all the emails are there and they're not. – Catfish Feb 5 '15 at 4:39
  • Where do you see the 1200+, and what it means Account no longer active? (was it a IMAP account) – Ruskes Feb 5 '15 at 7:56
  • It was an IMAP account, and so it downloaded 1200 messages to my computer when i mapped it with IMAP. Now i removed my server where I was hosting the emails so they only exist in my local computer where I mapped it via IMAP. I'm just trying to export them all now to an mbox so I can import them at zoho.com – Catfish Feb 5 '15 at 16:07
  • As far I know the zoho email does not read (import) the Mac mbox type email files. You would need to convert the mbox to eml type first. There are some free tools to do that, and some that cost money (your choice). The thunderbird should be able to read (IMPORT) the mbox. – Ruskes Feb 5 '15 at 16:46
6

I couldn't get my export working even with a mailbox rebuild. However, my goal was simply to archive my old mail, and not necessarily to do so in the mbox format, so copying the raw mailbox with 'mv' was adequate for my purposes.

After some trial and error, I found the path was ~/Library/Mail/V3/IMAP-<account-name>/. Sharing it here in case anyone anyone else is in the same boat.

  • I guess you mean cp not mv – cglacet Mar 31 at 12:31
2

Ok, first lets get our numbers sorted out.

Select the mail box (Inbox) you are trying to export, then select all messages and use the Mark as Unread.

Now look how many does it shows in that Mail box.

Now the export should export all of them.

Next is to do the Import Mail box to verify. Use the Import Mailboxes in the File menu then select the exported mbox file. The count should be the same as export. Now you can delete the Import mail box that you no longer need.

This is not to be confused with the Inbox on the server (from your email provider), which you can only access true Internet.

Since your account is no longer active you can not get those messages from server anyway until you reactivate it, they might be still there for you to get them. If you deleted the Internet email account then the game is over.

In order to get more clarity, please specify what email provider were you using for that email.

  • There is no mark as unread option: snag.gy/doRyx.jpg. Account info shows 2766 messages snag.gy/ucweJ.jpg – Catfish Feb 13 '15 at 14:19
  • 1
    Thanks for the screen shots. First when you use Mark as Read, then go again now it has changed to Mark as Unread, it is a flip flop switch. second, your mail Inbox shows 1199 unread messages- but it also show the warning sign that that Inbox is not online (not connected to the server. When you do the get Account Info, it goes to your ONLINE account and shows you the situation there. You have a warning there saying that account is offline thus the numbers do not match. If you follow my procedure above, to test the export from your Inbox that is in your Mac Mail. – Ruskes Feb 13 '15 at 17:18
  • Please do not confuse the 2 Inbox. One is on your Mac, the other is on the server (Internet connection). You do not have 2766 messages on your Mac mail to export, those are on the server. You would have to get them from the server first. – Ruskes Feb 13 '15 at 17:18
  • Ok after marking all as read then unread, there are 1382 on my local computer – Catfish Feb 14 '15 at 16:29
  • Thank you, so now the first test is to export all of them then import back in the mail and check the count to verify that the exporting works. Next step would be to test the importing in to Thunderbolt--Zoho. – Ruskes Feb 14 '15 at 16:40
0

I also couldn't export the entire mailbox - only 200mb were exported. After I did a Mailbox Rebuild (see Mailbox > Rebuild in the Menubar), all mails (1.25GB) were exported.

0

I have a deactivated email account, which I would like to backup all the emails locally as .mbox, and can be easily further transferred between different email client (i.e. from Mac Mail to Thunderbird etc).

But every time, I select a mailbox --> (right click) Export Mailbox, it only exports around 25 emails out of the total 2000+ emails..

By accident, I found a trick worked for me. One has to select a mailbox folder, and uses the small settings (gear) icon at the bottom of the panel, to do the export! Then you will find it will export all the emails contained in that folder! This worked for me at least, but it seems it is definitely a bug of the software..

the button

0

Solving the annoying Some messages could not be imported - Error in Mail.app.

I figured out a pretty easy way to copy all E-Mails from my old MacBook to my new machine with Mail.app.

(MacOS Mojave 10.14.2; Mail 12.2)

Don't export your mailboxes as .mbox (Mail.app > Mailbox > Export Mailbox...)

I pretty much always got the following error when I imported the previously exported .mbox files to my new Macbook:

Some messages could not be imported. The partially imported mailboxes are located in the mailbox named “Import” in the mailboxes list.

The odd thing is that Mail.app doesn't tell you which E-Mails have not been copied. This uncertainty is very frustrating especially when you want to move thousands of E-Mails.

There is a simple workaround using EMLs instead of .mbox:

  1. In Finder create a folder for every mailbox you want to copy. In any case you should create a minimum of 2 folders. You’ll see why soon.
  2. In Mail.app select one mailbox at a time. Select all mails inside and drag & drop them into the corresponding folder in the finder. The mails are copied into the folder as EML.
  3. On the new machine open Mail.app. File > Import Mailboxes… > Import data from Apple Mail
  4. Important! Select at least 2 folders to import. If you only select one folder, Mail.app imports every EML file in its own mailbox! (This would work but it takes long to delete the empty mailboxes after you’ve moved all the mails into one mailbox.)

Done! With this technique I've copied thousands of E-Mails from one Mail.app to another Mail.app without any errors.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .