74

Not sure how long this has been happening, but I just noticed it AFTER Yosemite update.

Mission control just does not work: using hot corners, keyboard shortcut, or even double clicking Mission Control.app, there is no way to make my Mac go to Mission Control/Exposé. By the way, I have hot corners for showing desktop and app windows exposé, neither of which work. Hot corners for dashboard and Notification center work as usual.

Any ideas why does it happen, how could I solve it?

Thanks a lot.

12 Answers 12

132

(This irritating bug seems to be biting me more often after updating to 10.10.4)

When this happens and I don't want to have to reboot, I only restart the "Dock" process and the problem is gone. There's probably some GUI way to do it, but I just drop into Terminal and do:

killall Dock

But before that, run killall -s Dock to see what would be killed, to make sure it's only going to directly kill the one "Dock" process.

Once you run killall Dock, Dock will restart in a few seconds and then Mission Control is working again. You can verify that the restart happened by checking the Process ID of "Dock" after the restart.

7
  • It is interesting that as soon as I started terminal to apply your solution, Mission Control started working again. Could it be that merely starting the terminal is fixing the issue?
    – turzifer
    Dec 30, 2015 at 12:03
  • 1
    @Conrad A good thing to do is to set it up as an automator service and launch it through a keyboard shortcut. That way, you just press some shortcut that nothing uses and you have got your mission control without dropping into terminal.
    – John K
    Mar 20, 2016 at 12:02
  • It appears my issue was related to WindowServer talking to something - and error like this was abundant in my system log: Aug 18 11:05:52 XXXX WindowServer[1444]: 7163832619276: ++ Phase Began type: 6 conn: 0xc42b, window 0x0
    – cgseller
    Aug 18, 2016 at 15:10
  • OMG this has been bugging me for literally years. The symptom I'd had was that Command-Tab wouldn't switch Spaces to the app's space (despite the relevant preference being enabled) until I restarted. Killing Dock works. Thanks so much! Oct 9, 2017 at 18:15
  • Thanks! Also works in macOS Mojave :) Jul 3, 2019 at 11:08
17

The GUI way:

  1. Open Activity Monitor.
  2. In the search field, type in 'Dock'.
  3. Select Dock in the results.
  4. Click on the black X directly above on the left.
  5. When asked if you are sure you want to quit the process, choose Quit.

The Dock process will quit and restart. All your gestures/shortcuts will now work again.

2
  • it is easier to open terminal and type killall Dock.
    – Duck
    Aug 17, 2017 at 17:06
  • I see no relation between Dock and Firefox.
    – Duck
    Jun 28, 2020 at 12:01
15

I found that the file responsible ist com.apple.dock.plist which sits in ~/Library/Preferences. In this file exists an entry to enable/disable mission control.

For me this procedure helped to get mission control working again:

  • Start terminal and execute the following commands:

  • defaults write com.apple.dock mcx-expose-disabled -bool FALSE
    (this enables mission control)

  • killall Dock
    (kill and automatically restart the Dock, this is necessary to get it done)

6
  • This is the only thing that worked for me. May 22, 2016 at 15:05
  • This worked perfectly. I wonder what disabled this in the first place 🤔
    – iMaddin
    Nov 8, 2016 at 19:10
  • I agree, this was the only thing that work for me after researching for a couple of days. Thank you, Ronald.
    – dandaman12
    Sep 18, 2019 at 13:22
  • thank you thank you thank you! I was getting so tired of people writing killall Dock. I think that the Pearson VUE testing app actually was responsible for messing this up - great find!
    – Mike Homol
    Jun 10, 2020 at 12:44
  • You just solved 6 month-long problem for me. After trying so many things, I took it to even so-called "Genius Bar" and they also couldn't do anything. I was on the verge of changing hardware and you probably saved bunch of money and effort. I literally owe you! I'm a software dev and if there's anything I can help you with reach out via petappmelbdev@gmail.com - I check this occasionally.
    – Illuminati
    Jul 11, 2020 at 3:03
2

I had this issue as well when I updated to OS X El Capitan (Version 10.11.4). Found out my dashboard got switched to "Off." What worked for me is to:

  1. go to System preferences
  2. open Mission control
  3. make sure "Dashboard:" dropdown is set to "As Overlay".
1

I just had a similar problem (also under Yosemite) - mission control was still accessible with function keys but not with gestures. It came back with a reboot.

1

I have 10.12.5 beta and my Mission Control stopped working as well.

I used this process and it helped to get mission control working again:

Start Terminal and execute the following commands:

defaults write com.apple.dock mcx-expose-disabled -bool FALSE (this enables mission control)

killall Dock (kill and automatically restart the Dock, this is necessary to get it done)

It didn't seem to work BUT when I activated a hot corner, it all came back. I can swipe up w/ the track pad now and use expose. I deactivated the hot corner short cut and it still works.

0

There is an additional way to reactivate mission control hot corners activation. This is possible by refreshing "system preferences" of mission control hot corner configuration.

You have to go to "system preferences", open mission control preferences, select hot corners. Change one of the hot corners possibilities, and go back to original settings. After this selection change, everything is back.

0

In addition to Mission Control, I also have Screen Saver assigned to a hot-corner and engaging the screen saver, then exiting, fixes the issue for me.

I haven't tried engaging the screen saver via hot-keys, but I did try to "Preview" the screen saver from system settings and that didn't work for me.

I'm on El Capitan now, but have had this issue for at least the two previous OS releases.

0
  1. go to System Preferences -> keyboard -> shortcuts -> Mission Control
  2. disable all "Switch to desktop"
  3. execute in Terminal: killall Dock
  4. enable previously disabled shortcuts
0

Had this issue November 2016 running OS 10.12.1 "Sierra" an additional symptom is that hot corners were not working. I fixed it by opening Activity Monitor, Quit the dock (force quit was not necessary). Went back to normal

0

I had this problem and tried all of the above. Turns out my function keys were set to be standard functions keys, not the apple special key overlays. Fixed in Keyboard settings with one click. I reckon one of my kids changed it over at some point when playing a game ...

0

For me, F3 didn't work but ctrl+up did, tried all answers here and nothing.
So, I checked with the keyboard viewer if the keys were working as expected and that was the reason, F3 key simply stopped working.
So I just simply changed the default ctrl+up behaviour to work with F5 (I don't need to control keyboard brightness as I have a standard keyboard) and problem solved (clearly, when I get used to this new key).
enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .