2

While trying to install Windows 7 via Bootcamp on my MBP Retina today I really messed up.

After getting into the drive selection in the Windows installation utility I deleted the other partitions (3 of them - as I remember one 60mb, one 200mb,) to get more space for my Bootcamp partition. After I deleted them (not formatted anything - just deleted) it just showed one huge unpartitioned disk with the whole ~250gb of my ssd. I realized that I messed up and exited the installation routine just to find out that I can't boot into anything right now.

When I do a regular restart it shows an error message "no bootable device - insert boot disk and press any key" - I also tried the "alt+cmd+r" method which doesn't do anything...

Please send my any ideas/tips how to go on - I have really important documents on that machine and I haven't made any backup.

UPDATE:

I tried to connect it to a second mac via thunderbolt/target disk mode and get the data with testdisk but i'm kind of stuck - when i connect it first it says something like "the medium couldn't be read" but I'm able to see the ssd via disk utility! But what medium should I select in Testdisk?

testdisk output

  • Great job :) the 200mb was the EFI responsible to boot your system. Normally that partition is not visible, but in your case it was. The cmd+r should still work if you have not deleted the 600mb recovery partition as well. – Ruskes Feb 4 '15 at 16:58
  • that's what i guessed :/ - any chance to recover from this? i also deleted the 600mb recovery part... – Peter Piper Feb 4 '15 at 17:03
  • so stupid ... i thought that wouldn't cause any damage if i won't hit "format" ... are there any tools to access the data? maybe from another machine/bootable stick etc? – Peter Piper Feb 4 '15 at 17:03
  • Sorry if this comes over a bit harsh, but... the golden rule, which you just learned the hard way, is 'never let Windows mess with the partitions on a Mac. It just doesn't understand them.' You might get some joy from TestDisk or the latest version of DiskWarrior but you also just learned why backups are important. – Tetsujin Feb 4 '15 at 17:10
  • ^^yes i learned a lesson here :/ - but thank you guys for your tips! - so i'll try to run testdisk via target disk mode from another mac!? – Peter Piper Feb 4 '15 at 17:12
1

It looks like you manged to delete a Hidden partitions.

One is Called EFI and it is about 200mb.

The second one is called RecoveryHD and it is about 600mb.

There was a reason for them to be hidden, but if you have the Debug menu show all on, they will show.

The good news is your data is still there, if you did not do further damage.

If you have a bootable USB (always) then use it to start up.

Meanwhile if you must recover your data, use a second Mac and run the Target Disk mode to recover.

Using 3d party disk repairs wont help here, you need to get the EFI back on to your disk, that is only provided by Apple.

  • I haven't had the opportunity (need;) to test it, but the new DiskWarrior says it can rebuild partition damage. Would be interesting if someone who already owned it got chance (bad luck) to have to try it out & see if it is as good as they say. – Tetsujin Feb 4 '15 at 18:10
  • ^^i'll try it out and let you know if i succeed! – Peter Piper Feb 5 '15 at 12:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .