1

I recently ran into this problem when doing desktop support for a user, and wanted to share the solution. They had deleted the Google Drive app and re-installed it, but then kept seeing this error dialog when they tried to open the re-installed app:

Google Drive error dialog

When I tried uninstalling it (i.e. by dragging it to the trash), I kept seeing another error dialog that said that the application was running (and therefore couldn't be moved to the trash), but the icon in the taskbar wasn't there. I tried searching for the process:

$ ps -ef | grep -i drive
  202  208    1  0  2:06pm ??        0:00.06 /System/Library/Frameworks/CoreAudio.framework/Versions/A/XPCServices/com.apple.audio.DriverHelper.xpc/Contents/MacOS/com.apple.audio.DriverHelper
  501  292  194  0  2:06pm ??        0:03.04 /Applications/Google Chrome.app/Contents/Versions/40.0.2214.94/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=gpu-process --channel=194.0.484367729 --supports-dual-gpus=false --gpu-driver-bug-workarounds=4,13,22,25,27,36,39,41,44,50 --disable-accelerated-video-decode --gpu-vendor-id=0x8086 --gpu-device-id=0x0a26 --gpu-driver-vendor --gpu-driver-version
  501  526    1  0  2:12pm ??        0:01.29 /Applications/Google Drive.app/Contents/MacOS/Google Drive
  501  588  537  0  2:15pm ttys000    0:00.00 grep -i drive

And was only able to kill its process with kill -9 (yes, I tried the other kills first...), after which I was able to move it to the trash.

I tried reinstalling it with a fresh installer from the Google Drive website but kept on running into the same issue.

3

On my system (10.10.2), the corrupted Drive file was in $HOME/Library/Application Support/Google/ -- deleting that solved the problem.

Or for you command line wizards:

$ rm -rf '~/Library/Application Support/Google/Drive'
1

Turns out there are some lingering files under the user's home directory: go to $HOME/Library/Google/ and delete the Drive folder in there. Everything should work after that.

You must log in to answer this question.

protected by bmike Jun 25 '17 at 14:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .