3

Hopefully a simple solution. I installed a recent Starbucks app, and noted it was tracking my location and popping up on the lock screen. I do not want that. At all. Even after setting not to show on lock screen, it shows. I finally just removed it, but wondered as to how to get it to stop? I even turned off location tracking and yet it continued.

I wonder if having the older version still on my phone might have caused this?

5

This sounds like the iOS suggested apps (they can appear as an icon on the bottom left of the lock screen). You can turn the suggestions off in the Settings app under General -> Handoff and Suggested Apps

Handoff and Suggested Apps settings

  • hey thanks, i was at that screen but completely misread it. It seems far too over-reaching to shut them all down in one fell-swoop, but hey, i am just one opinion. As an apps developer, this stuff is generally intuitive to me, but not this time, thank you. – drew.. Feb 3 '15 at 4:55
  • 3
    @drew For what it's worth I don't believe suggested apps are given your location. It's iOS knowing your location and thinking the app might be useful to you there. i.e. "You're near a Starbucks, I'll make it easy for you to launch that app if you want it." – D.G. Feb 3 '15 at 4:58
  • This setting is not present as of Dec 2018 in iOS 12.1. The correct answer is to go to Apple Wallet and edit the settings for the Starbucks pass. See the other answers to this question. – Jason Dec 1 '18 at 15:56
7

It may be because you added as a passbook pass. If it only shows up when you are near the store, that's the reason. Go to the Starbucks app, click Stores at the top, click the store you are at, and hit the X near the passbook option.

(You can also delete the pass directly in Passbook.)

  • The current version of the Starbucks app appeared to add a pass programmatically. I favourited a store and got the lock screen notification. Later I found a Starbucks pass in Wallet. – sigint Nov 2 '16 at 10:28
2

Go to the passbook/wallet, click the app, then the little i for information, uncheck show on lock screen.

0

Settings....starbucks...notifications.... Toggle : Show on Lock Screen

0

Don't uncheck "show on lock screen". That will make it disappear from the wallet on lock screen. Go to Starbucks app - Store - click on the store that shows on your lock screen - unfavorite it. Now you can still use your Starbucks card if you double click the home screen for Apple Pay, but you won't get an annoying notification when your near the store.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .