Transmit and Forklift are paid, we can't use finder, macfusion doesn't work... so I'm wondering...

Is there any free option left to mount an FTP on finder so that I can write files to it? Maybe using scripts or automator? Maybe fixing my issue with macfusion? I don't even know why my installed macfuse is 2.1.7 (beta) while it asks me to "update" to 2.0.3 or, if I tick "Show Beta Versions", 2.1.5! In general, it looks to me the whole thing is too unstable yet.

Last case, I'll just stick with CyberDuck. And yes, I've just tried them all except automator.

  • 3
    Maybe you could go in to detail on what failed when using MacFUSE or Macfusion? Both of those work for me in OS 10.6.8. Macfusion in particular for mounting EC2 shares over SSH and FTP shares.
    – Ian C.
    Jul 6 '11 at 14:26
  • @Ian fair enough, I'll get into details later, but for now I hope it's suffice to say they both install and run ok, but I tried copying 1 file from local to remote and it never went through.
    – cregox
    Jul 6 '11 at 15:58
  • 1
    Just an update and heads up @IanC., after randomly finding this question again. It's still open and I did update it with MacFUSE issue, which is still unsolved. So, I've been using CyberDuck since then indeed.
    – cregox
    Sep 3 '12 at 16:19

You could create a tiny Automator application to do the job.

Inside of Automator, add the following two actions to your workflow

  1. "Get specified servers" Specify your server/servers in this action as follows: ftp://username:password@yourserver.com
  2. "Connect to servers"

(The names of the steps might not be a little off since I'm not running an English version of OS X)

Save this as an application and start it whenever you need. You can also make it a startup item in System Preferences > Account under the Startup items tab.

  • Are you telling me I can mount it on the terminal to appear on finder? If so, I had no idea we could do that.
    – cregox
    Jul 6 '11 at 18:07
  • 1
    No, I'm trying to explain the procedure of creating an application through Automator that will connect to and mount your FTP share. I've edited the post to make it a little more clear.
    – Sebastian
    Jul 6 '11 at 21:17
  • 7
    Mac OS X's built-in ability to mount an FTP server as a filesystem (via Finder "Connect to Server..." or "mount_ftp" in the Terminal) can only mount read-only.
    – Spiff
    Jul 7 '11 at 5:34

Not the answer you're looking for? Browse other questions tagged .