1

I'm having an annoying problem with Mail on Yosemite, which I didn't notice on earlier versions. Basically if I suffer a connection issue with my ISP's mail service (which does sometimes become slow to respond during peak hours) then Mail seems to try alternative ports.

This would be fine, except that it eventually settles on port 143 with SSL disabled, at which point it refuses to connect (because it can't send my password securely), but it has now changed the account's port permanently to 143, meaning I have to change it back before I can use my e-mail account again.

Is there a way to prevent Mail from doing this? I've set the correct port for the account, and know it's correct, so I don't want Mail to ever change it, but it keeps doing this any time the connection takes a bit too long to respond.

1
  • how to detect the port used for a certain account?
    – Walter
    Dec 21, 2018 at 9:53

1 Answer 1

2

Make sure you've switched off the new 'Automatically Maintain' settings that appeared with Yosemite.

Two places, outgoing & incoming...

for each account

enter image description here

and for each Outgoing Server

enter image description here

2
  • Aha! That seems to have done the trick, seems like buggy behaviour though, might file a bug-report as well, as it really shouldn't change settings if they result in an error.
    – Haravikk
    Feb 3, 2015 at 20:15
  • For sure - drove me mad til I found out about the new 'helpful' pref. ;)
    – Tetsujin
    Feb 3, 2015 at 20:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .