3

my internal keyboard and touchpad - stopped working a few days ago. When it first happened - I made the macbook sleep-wake-up several times - and it came back to normal. External keyboard+touchpad - work normally - but internal keyboard keeps randomly 'typing' in characters for me, especially 'fn-f' keys (such as randomly muting/adjusting volume, etc). If I reboot into 'Rescue mode' - they work flawlessly, but in 'safe boot' - they keep misbehaving. I've tried already NVRAM+SMC reset chords on startup. The rate of the problem is becoming worse, that it, it's less and less likely the internal input devices will work (immediately after sleep). I've checked preferences and touchpad is enabled, no-keyboard-keys etc. Any advice? OS-reinstall? anything to post here? thank you!

as suggested somewhere, I list here the non-apple kernel ext, it's only Virtual-Box, which was install about two-month before the problem appeared:

$ kextstat | awk ' !/apple/ { print $6 } ' org.virtualbox.kext.VBoxDrv org.virtualbox.kext.VBoxUSB org.virtualbox.kext.VBoxNetFlt org.virtualbox.kext.VBoxNetAdp

Can I try to reinstall the internal macbook keyboard drivers w/o entire os reinstall? thanks.

Edit: One week later update:: Situation is still not solved, but I'm more convinced it's a "sleep wake" related thing: I was using the computer 'normally' now for a week (without shut-down, 'sleep' - only using Lid-Close). When once- I press the Menu-Sleep - on wake-up - I had no keyboard and pad. I had to close the Lid and open it several times- after 3 times - It woke up working. Another time - after full shut-down (from menu) - the computer woke up (after 30 minutes when I turned it on) - with no keyboard-pad again. (last night). I left it on 'Lid-Sleep' - and in the morning now - it's working again. Yesterday - also the Volume and keyboard light buttons - stopped working till reboot (sleep didn't help) - they were in a weird-state - where they would display their 'squares' showing their meters on the screen - but they would not affect the actual volume and keyboard light level. Neither did the volume control from the top-bar. (Though the volume control inside the "System-Pref/Sound" - still worked properly), I don't know whether it can be related, but I'm providing this hint. I rebooted because of this, and on the reboot - (the mentioned 'shut-down' from menu) and the computer woke up with no keyboard. When I find a solution I will post it as an "answer".

  • 1
    Same problem on my MacBook Pro (Retina, 15-inch, Late 2013) after update to 10.10.2!! Only additional info is that USB mouse or keyboard do work; only the internal devices are unresponsive. – Leon Gondi Feb 4 '15 at 19:41
  • This also started after my update from 10.10.1 to 10.10.2. Luckily - the internal devices - are working again now. after about 48h of not working. I was using an external wired keyboard+mouse for there 48h. Somehow it works again (I haven't done anything, and it went back to work after 'sleep'). Luckily - it's still working for the second day in a row now. I'm still afraid it might start again. I'm planning to try reloading the kext as mentioned here: – oyd11 Feb 5 '15 at 21:05
  • $ sudo kextload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext apple.stackexchange.com/questions/67133/… – oyd11 Feb 5 '15 at 21:05
  • still same problem. Consistently after every reboot now. Luckily - it goes away ~ 1 hour after the reboot. Sometimes I'm also lucky enough to have an external keyboard around (still some ghost-keys are being pressed from the internal keyboard or whatever). Waiting for the next Yosemite update which might solve it. – oyd11 Mar 4 '15 at 10:16
  • Hitting the exact same issue. It's definitely a sleep-wake thing. Works fine, close lid, open 15 minutes later, and no touchpad or keyboard. Plug in an external mouse/keyboard and they work fine. – user118398 Mar 16 '15 at 21:10
1

Apple doesn't package the drivers or installers, so the best you could do is try these installs.

  1. Download the latest "Combo" updater for 10.x.x and install that package.
  2. Download the entire Yosemite Installer and then re-install the OS.

The only downside to option #2 is you need to download more data. It is the sure fire way to ensure everything is up to date. The only downside to #1 is that it might not work. Not everything is packaged in the combo updater - just the things that were updated. So if you choose that, you might waste the time downloading the small package and trying to install it.

Before you do anything, try rebooting in safe mode. That would disable any third party kernel extensions and let you know if the core OS is the problem. If the keyboard works there - you might just need to uninstall your VM and other modifications.

  • 'Combo' didn't help. reinstall - postponing. Safe-mode - as written in the original question - doesn't help, but on "Rescue Mode" both works, and on "Single user shell" the keyboard works. For now - I've just found this none-solution: 1. pray before each reboot 2. after a "bad reboot" - work with external keyboard+mouse - and the internal ones come back after 3-4 hours. Then - avoid reboot - avoid "sleep from menu", lid-sleep - is ok! – oyd11 Feb 13 '15 at 23:21

You must log in to answer this question.

protected by Community Sep 10 '15 at 8:30

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .