I've run Yosemite for some time now, this issue is recent. My assumption has always been that Time Machine autonomously overwrites old backups once your time capsule is full.

So my question is :

How do I resume normal Time Machine backups without having to manually erase old backups. I know I can delete files from Time Capsule

Running: 10.10.2

Time Capsule :

461 GB of 2TB available...backup error is

The backup disk needs 536.69 GB for the backup but only 460.78 GB are available. Select a larger backup disk or make the backup smaller by excluding files.

  • After i deleted old backups. This error finally came back today, 6 months later. Why isn't time machine doing this autonomously? Isn't that it's purpose?
    – soulshined
    Commented Aug 21, 2015 at 12:10
  • I would be tempted to close this for an edit and refund your bounty. We strongly prefer one question per question. Let me know if you'd like to take advantage of the refund to split this up / narrow what you need help with. 1 and 2 are not related. Once you understand them - you might need more help with 3. Also - what build and version of OS X are you running?
    – bmike
    Commented Aug 25, 2015 at 20:16
  • hey @bmike thanks for the feedback. For what it's worth, I can just omit the first two points, as they are irrelevant, and just edit the question? The core issue is how do I resume normal backups as intended by Apple. Running 10.10.5 iMac8,1
    – soulshined
    Commented Aug 25, 2015 at 21:03
  • Are there any "other machine" backups also on the same time capsule? TM will only delete older backups of what it thinks is the same machine (ie, other machine backups aren't deleted)
    – Kent
    Commented Aug 26, 2015 at 2:50
  • Just an outside possibility - one or more VM HDs needing a lot of space with every tiny change?
    – Tetsujin
    Commented Aug 26, 2015 at 7:57

2 Answers 2


This somewhat of a long shot, but it sounds a little like you may have changed something on your disk. "Invisible" actions like changing file permissions or HFS+ compressing files will cause TimeMachine (TM) to assume that the files have changed and need to be backed up. Another scenario would be that the UUID of your hard disk changed. This article lists some further possibilities. So to answer your questions:

  1. the warning is there because you would loose all previous backups and you would be left with only this one backup.
  2. Time Machine thinks that all files have changed. My hypothesis is that you did some action changing attributes of all files or your disk's UUID.
  3. you could try to inherit the files

I suggest you try the following:

  • Compare your disk's UUID with the one used in your Time Machine:
    1. diskutil list and
    2. look for a hidden file called com.apple.backupd.SnapshotVolumeUUID on your TM disk (not too sure about the file name, because I use sparsebundles)
  • Full Reset of Time Machine: Read this article for details. Basically you will have to delete /Library/Preferences/com.apple.TimeMachine.plist
  • Reconnect your backup. Read this article thoroughly. You will have to use either of these commands:
    • sudo tmutil inheritbackup /Volumes/myTM/Backups.backupdb/myMac or
    • sudo tmutil associatedisk -a / /Volumes/myTM/Backups.backupdb/myMac/myDisk

Note that you might loose your entire backup. Please make a copy of your Time Machine backup.


I also had the same problem in Mac OS X Mountain Lion or Lion.

First of all, your main question is true: Time Machine should remove old backups when disk comes full, and that's some strange behaviour you're having.

What solved my problem was simply resetting the Time Machine preferences by removing the file /Library/Preferences/com.apple.TimeMachine.plist

When you do this, Mac OS will forget your disk and when you will connect it again it'll ask "do you want to use this disk as Time Machine?". I said yes and started a new backup, which went fine.

Also, I hope you're not removing old backups simply trashing folders from the Finder: to manually remove old backups you should enter the Time Machine, select the backup you want to remove and click on the gear-icon and then select Remove Backup. If you simply moved old backups in the Trash, that's not a good way to go: you probably corrupted some of the internal indexing in the Time Machine (and that's maybe why he asks for more data). As my knowledge, there is no cure for that other than erasing the disk and start a new Time Machine again.

  • By removing old backups, I restored it to factory settings and redid the process (12 hours later a successful time machine backup; 6 months later, today happened). I have not tried the plist option, which both answers have in common, so that should be my priority in the morning. thanks for trying though.
    – soulshined
    Commented Aug 22, 2015 at 2:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .