1

Virtualbox complains that VT-x isn't available and running securable confirms that it's not available. My 2012 rMBP has an i7 and intel clearly states the CPU does have VT-x, nevermind the fact that Virtualbox works just fine under OSX. This is where if I had a PC I'd check if it was enabled in BIOS.

What can I do?

1

Okay so I got it working with virtualbox with the help of VMWare. I tried AnonymousAppDev's answer but it didn't have any effect on my machine (at least not after the first reboot).

I read that VMWare may be able to turn on VT-x, so I installed VMWare workstation. That in turn asked me to remove Hyper-v since there's a conflict. After rebooting securable now says I have VT-x enabled and I'm able to run Virtualbox.

| improve this answer | |
  • Same here. Just removing hyper-V from windows 10 solved everything – Korayem Sep 8 '16 at 9:05
0

It is supposed to be enabled. However, I searched around, and this is what I found:

Instead of booting into Windows by holding the option key on startup, boot in to OS X. Then go to System Preferences -> Startup Disk and choose your Boot Camp partition. The computer will restart and boot into Windows, with virtualization enabled.

That is from https://superuser.com/questions/717421/how-to-enable-hardware-virtualization-on-a-macbook

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .