2

I have a table in numbers, and I want a cell to equal the value of a cell in a different table. Following the advice of this Apple discussion, I tried

=Units Sold::B2

, with Units Sold being the table with the value I wanted, and B2 being the value I wanted in the table "Units Sold".

enter image description here

To clarify, I want D2 of "Juice and Beverages" to equal the value of B2 of "Units Sold".

What am I doing wrong? Numbers for iCloud gives the error

The formula contains an invalid reference.

Thanks!

  • The syntax is correctly formatted, maybe you have formatted the cell to something. Once you start typing the table title it should auto populate after = – soulshined Feb 1 '15 at 18:59
  • @soulshined OK. If that is the case, how can I make it work? – rocket101 Feb 1 '15 at 19:00
  • Format your cell to 'Automatic' then proceed like normal. Type = then start typing Units Sold::B2 it should work. Or do what grgarside has displayed – soulshined Feb 1 '15 at 19:02
  • @soulshined Both cells are formatted to automatic, and it still doesn't work. – rocket101 Feb 1 '15 at 19:06
  • Try ⌘+Q and reopen Numbers and try again, there's nothing wrong with the syntax – soulshined Feb 1 '15 at 19:13
3

It does work in iCloud Numbers:

Select the cell you want the result in: i.e D2 of "Juice and Beverages"

And then in the text field at the top of the page enter:

=SUM('Units Sold' :: B2)

Take note of difference in how I have written it and how you did. Which was you main problem.

enter image description here


When done, click the green tick button on the right. And you will see this as the end result.

enter image description here


You can see some documentation on some of the included Functions by clicking into a cell and then into the:

1, text filed above:

2, you can search for a formula.

3,insert a Function template into the text field.

4, see a description of the Function and scrolling down further in the description you will see examples.

enter image description here

2

Cross-table referencing is not currently possible in Numbers in iCloud.com.

In OS X, if typing doesn't work, simply press = then click the cell that you want to reference.

  • Not working - the cursor just appears in the cell I am trying to select. – rocket101 Feb 1 '15 at 18:59
  • @rocket101 You need to be in formula edit mode to click-select cell references. Make sure the formula edit bar is active. Alternatively, type the reference (see the left animation). – grg Feb 1 '15 at 19:02
  • It doesn't work in formula edit mode, the same thing happens. Bug? – rocket101 Feb 1 '15 at 19:07
  • @rocket101 This sounds like a bug then. Try it with a new spreadsheet to see if it's the spreadsheet. Do you have the latest version of Numbers? – grg Feb 1 '15 at 19:09
  • @I am using numbers in iCloud – rocket101 Feb 1 '15 at 19:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .