0

I have come across this problem several times now before I finally decide I should try and be doing something about it. Basically this seems to be happening when I am multitasking with iTunes playing files stored on my local SSD, Safari open with multiple tabs, and a text editor / IDE for work, and I may have Preview, Excel and Mail open too. I have the Macbook Air Mid 2013 with i7 processor, 8GB RAM and 512GB SSD, on Yosemite (pretty sure it happened on Mavericks too).

When my laptop hangs, the music is stuck on a frame and it just keeps on repeating it over and over. At that point the entire system is non responsive. The display, the keyboard, the sound, it's like flipping on a light switch but the bulb stays on. The only thing I can do is hold the Power button to force restart.

I suspect a problem with iTunes, but it could be with the OS itself. The problem is I don't have any crash report or stack trace to make sense out of this and the problem happens maybe once a week or two.

How would you guys troubleshoot something like that?

EDIT: please bookmark this if you have the same problem. I'll update with observations, findings, etc.

  • i got a similiar problem. Does the macbook work again after rebooting? if not try to reboot into recovery (cmd + r after boot sound) and in Disk Management, check permissions and solve them. If it works again you can open the error log and switch to the time it happened. There you see maybe a usefull error. – TheDomis4 Feb 1 '15 at 14:55
  • Yes, it works fine. Like I said, nothing in the error log, which says something about the problem of itself, but I did just repair my permissions. It had been a while since I did that. I'll update this post after a while with any observations. – believesInSanta Feb 1 '15 at 15:07
  • @TheDomis4 btw, you have a similar model MacBook? – believesInSanta Feb 1 '15 at 16:43
1

sry cant comment (reputation)
i have an older Macbook Air mid 2009 13" with 2GB of RAM and SSD, but found that many user experience similiar bugs as i do on Yosemite: https://discussions.apple.com/thread/6624349 (some on macbooks, some on iMac's)

it seems like i solved mine (for now, had no problems for the whole day) by resetting PRAM/NVRAM multiple times in a row. Im still not sure which caused the problem. Alternatively if i will go back to Mavericks or Mountain Lion. Yosemite feels to me like Windows Vista (altough i like the design)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .