I have removed the "guest user" account by: System Preferences → Users & groups → Guest User → Remove.

It still remains as an option under users (but states disabled).

It still shows up on login screen and if selected allows guest to logon to computer.

How do I remove guest login completely so that is is not even an option at login?

  • Do you have the Find My Mac service (part of iCLoud) enabled? Feb 1, 2015 at 6:07
  • I do not have find my mac enabled.
    – Jim
    Feb 1, 2015 at 19:25
  • delete the account?
    – OzzieSpin
    Oct 4, 2016 at 9:14

9 Answers 9


How to disable that “Guest User” from appearing at the OS X login screen

For modern versions of OS X, disabling Guest account is done as follows:

(I have provided a screenshot from El Capitan, but Yosemite is very similar)

  1. Open System Preferences

  2. Go to “Users & Groups” and click the unlock icon

  3. Click on “Guest User”

  4. Uncheck the box for ‘Allow guests to log in to this computer’

enter image description here The key here is everything must be disabled. Once you completely disable the account, it will no longer show up on the login screen.

If you have older versions of OS X, follow the instructions below:

Disabling Guest User in OS X Lion, Mountain Lion

  1. Click on “Security & Privacy”
  2. Click the lock in the lower corner and type in your administrative password to unlock the control panel
  3. Check the box next to “Disable restarting to Safari when screen is locked”

Open Terminal and run

sudo defaults write /Library/Preferences/com.apple.AppleFileServer guestAccess -bool NO
sudo defaults write /Library/Preferences/SystemConfiguration/com.apple.smb.server AllowGuestAccess -bool NO

The easiest solution I found was to go to "Directory Utility" (You can use spotlight search to find this),

Once at the panel, unlock the padlock on the bottom left of the panel.

Go to directory editor, make sure the "viewing" tab is selected on "Users"

Then go to the search bar on the panel and type in guest.

You will see "Guest User" under the search bar and select it

Then press the minus button on the bottom left of the panel.

Then, you restart your computer and then tada, its fixed!

This solution came from a official apple software engineer and it actually worked, however since this problem came apparent to the engineers they decided to fix this in the next update coming soon. So maybe you could also hold tight for a little bit and the issue will fix itself.

  • Sorry about that, I mean “search” I corrected the error Jun 4, 2021 at 15:30

I just tested this on 2 iMacs one from 2012 and one from 2009 both running Mac OS 10.13 and both have 2 login possibilities: the user's login button and an "Other" login button which asked for inputs for user name and password.

The true culprit here is whether “root user” is enabled or disabled. Here is how to check and disable root user if necessary:

  • Go to the users & groups pref pane and unlock it with an admin password. Click on “login options” in that pane.
  • Click the edit or join button a dropdown will appear
  • Click on the Open Directory Utility button. That takes you to the Directory Utility pref panel and you need to unlock that with an admin password.
  • Once that is unlocked from the Directory Utility Menu Bar at the top of screen select edit. If you see “Disable Root User” click on that and it will change to “enable root user” meaning the root user is not logged onto the system.
  • Back-track your steps and re-lock each pref.pane.
  • In Users & Groups you should have already turned off Guest User. Double check that the Guest User check boxes are still unchecked and now the selection for Guest User should be completely grey.
  • Go ahead and log off your user id under the Apple Menu and the resulting action should bring a login screen with the primary login name and password ONLY.

When Root User is enabled your login screens will always present an “Other” login button. Root user should only be active under special circumstances. Keep it disabled as the norm.


I no longer have an OS 10.8 Mavericks system to test on, but I think from your description that you had a real user account named "Guest" and deleted it. That enables the special Guest account, the one that's automatically created on each login and destroyed on each logout.

To disable that one, go back to System Preferences → Users & Groups → Guest User (he's baaack...), and uncheck "Allow guests to log in to this computer".

  • Unchecked and it is still showing up on login screen
    – Jim
    Feb 1, 2015 at 19:08
  • Then let's turn it around. Maybe you do have a normal user named Guest and haven't deleted it. In Terminal, the command id guest should return something that begins with id=201(Guest gid=201(_guest) groups=.... If you get a different id, one bigger than 500, then the Guest user you're seeing is a regular user. Also, if you're using FileVault, the list you see is the list of users who can decrypt the boot disk. That may include users who no longer exist. What happens if you log in as Guest? What do you see when Fast User Switching?
    – ganbustein
    Feb 2, 2015 at 20:28

If disabling won’t work, then you can also delete the account. The account does not exist in a default installation, but is only created when it is first enabled in Users & Groups.

sudo dscl . -delete /Users/Guest

Use the below command on terminal:

sudo fdesetup remove -user Guest and tap Enter.

It will ask for the admin password. Enter that password and the Guest user login will be removed.


Enabling the root user may result in an option of guest login at login window even if you have no guest user option anywhere at all. So, disabling the root user will keep guest user from appearing at the login window. https://support.apple.com/en-us/HT204012 has instructions on how to enable and disable the root user.

  • From the Apple menu choose System Preferences.
  • From the View menu choose Users & Groups.
  • Click on the lock and authenticate with an administrator account.
  • Click Login Options.
  • Click the Edit button or Join button.
  • Click the Open Directory Utility button.
  • Click the lock in the Directory Utility window.
  • Enter an administrator account name and password, then click OK.
  • Choose Disable Root User from the Edit menu.

Enabling root user may add the option of Guest User at the login screen. Since you don't have any Guest User, you should try disabling the root user. I have High Sierra and this worked for me. Works on Big Sur also till date.

  • Go to users and groups.
  • Unlock the page.
  • Go to Logon Options.
  • Join Network Account Server.
  • Open Directory Utility.
  • Unlock Directory.
  • Go to menu bar and open Edit dropdown.
  • Disable Root User.
  • Lock and close all windows.
  • Restart to test.
  • That's not the Guest User, that's the root user. Very different things.
    – JMY1000
    Dec 2, 2017 at 1:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .