7

On my iPhone, the App Store has a badge saying "2". When I open the App Store and go to the Updates page, there are two apps at the top, which for a split-second say "Update" and then immediately change to "Open". But the "2" badge remains. The apps are in the "Pending updates" section.

So I can't even update these apps if I wanted to, because either they have already updated or they are preventing me from updating.

I already tried hard resetting my device but no luck. I'd rather not take the extreme route of restoring my device if possible. Anyone know of any other solutions?

  • see if iTunes can fetch them, then sync – Tetsujin Jan 31 '15 at 18:03
  • 1
    I've seen this occasionally on my phone. Usually waiting 12 hours (e.g. overnight) or so clears up the issue for me. – dwightk Jan 31 '15 at 18:10
  • The problem keeps fixing itself a few times, but then it keeps returning. That's why I keep posting my answer to my own question and then deleting it... – Gary Feb 3 '15 at 16:43
  • 1
    Try re entering your Apple Store password. Or maybe it's an account problem, like expired credit card. – Sam Mar 15 '15 at 18:50
5

I had same problem and fixed it by closing the app down then reopening it, selecting the updates tab, then quickly press on 'update all' before the app updates revert back to 'open'.. You only have a split second to do this but it did work

  • After a few hours, the problem re-appears after trying this. – Gary Mar 27 '15 at 17:45
  • 1
    I keep tapping the corner before opening the app ;-) – ohho Sep 17 '15 at 1:55
3

Force quit the App Store (open the App Store, then hold power until the slide to power off slider appears, then hold home until the app quits), then reopen it and go to the Updates tab. Let it refresh the list and the problem should be resolved.

  • 1
    That didn't work for me. – Gary Feb 1 '15 at 4:05
  • This worked for me. Not on the first attempt, but it did work. iPhone 5S, iOS 9 (I think), Whatsapp (don't ask). – Mihai Danila Oct 12 '16 at 2:34
  • "Not on the first attempt" = I had to hit "Update" a few times. – Mihai Danila Oct 12 '16 at 3:07
0

Which iOS are you using? There is an issue where it won't update but opens when you press "update" if you're not on the iOS 8.x versions. The only way to update is click on the app and it'll take you to the details of the app, then you can update.

You must log in to answer this question.

protected by Community Mar 27 '15 at 12:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .