0

I use BindFS with OSXFUSE to mount some folders on an external drive on mount points within my user home folder. This is a sample line from my fstab:

/Volumes/Content/Pictures       /Users/Me/Pictures     bindfs  nobrowse,mirror=Me,volname=Pictures,xattr-none,local,multithreaded     0       0

Things work pretty well like this, except that if I turn the extended file attributes on (xattr-rw or even xattr-ro) I lose the writing capability on the mounts with a suspicious error:

The operation can’t be completed because an unexpected error occurred (error code -50).

I am trying to put some order into my files using tags, and I need to turn the extended attributes on in order to read and write tags. I wonder if there is a way to turn HFS+'s extended file attributes on for the mounts created using OSXFUSE and BindFS. If not, is this a general, unresolved bug/incompatibility?

Some technical info: I am running Yosemite with the latest updates. I install OSXFUSE using Homebrew Cask and BindFS using Homebrew.

0

These issues have reportedly been fixed in the latest version of BindFS. Try installing BindFS with head option and see if the problems persist:

brew install bindfs --HEAD

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .