0

My MacBook Air mid 2009 worked for 3 months without any problems on Yosemite.

Two days ago the built in mouse stopped working along with the built-in keyboard. Right after it woke up from sleep mode but the light is still on. After pressing the Power button, it asks me to shut it down, so the system did not crash.

At boot I'm able to clear the SMC and VFR (?) RAM. Both did not work. After I reboot, the machine won't respond to mouse or keyboard input. Also a USB mouse and keyboard won't work.

I always had to hard reboot the MacBook (holding power) After some time, it wouldn't boot (black screen). After leaving it off for ~5 mins, it would boot again, but I was faced with the same error. After some research, and the problems at startup, I think it might be an EFI specified problem. Reinstalling has only worked for half an day, then after wake up it wasn't responding.

The problem might be caused after the OS X 10.10.2 update. In the update log I couldn't find any EFI-specified updates (EFI and SMC is also up-to-date).

Anyone able to reproduce this error? I can't get it to work again (without reinstalling it).

  • Welcome to Ask Different! Answers shouldn't be in the question—feel free to self-answer your question by adding an answer below. – grg Jan 30 '15 at 15:50
1

I got a workaround to solve this error: Using CMD+R on Boot to access the Recovery Menu, i managed to check and solve Permissions on the SSD. There is one plist that says displayd should have 0 but has 244 (like that)

after solving, it seems to work... for half an hour again. Then i have to force-shutdown and boot into recovery again... The mac is virgin, theres nothing installed besides Firefox and Office '11.

that cant be it, anyone got a solution?

0

got the problem again. This time during copying files from external usb stick.

i could not do anything on the mac. Keyboard and mouse unresponsive, all USB devices where ejected. I hard-rebooted into recovery (the first 2 boot tries didnt worked, stayed on black screen) using disk-repair i got the following error:

User differs on "private/var/db/displaypolicyd"; should be 0; user is 244. Group differs on "private/var/db/displaypolicyd"; should be 0; user is 244.

after solving, i could boot again and the mouse and keyboard worked again. the error where between 14:22 and 14:24. i uploaded the error log to pastebin:

http://pastebin.com/b0zDwzL4

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .